Bug 1316637 - Non-prefixed dependencies in rh-nodejs4 packages
Non-prefixed dependencies in rh-nodejs4 packages
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-nodejs4 (Show other bugs)
rh-nodejs4
Unspecified Unspecified
high Severity high
: beta
: 2.2
Assigned To: Zuzana Svetlikova
Miroslav Hradílek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 11:20 EST by Miroslav Hradílek
Modified: 2016-05-31 06:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Certain rh-nodejs4 collection provides and requires are not prefixed. Consequently, this can cause conflicts with packages from the base Red Hat Enterprise Linux system or packages shipped in different products.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 06:17:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Hradílek 2016-03-10 11:20:36 EST
Description of problem:
Some collection provides and requires are not prefixed. This can cause conflict with main RHEL packages or packages shipped in different product.

Version-Release number of selected component (if applicable):
rh-nodejs4-2.2-5.el7.x86_64 (Unreleased)

:: [   LOG    ] :: rh-nodejs4-gyp
:: [   PASS   ] :: Checking for the presence of rh-nodejs4-gyp rpm 
:: [   LOG    ] :: Package versions:
:: [   LOG    ] ::   rh-nodejs4-gyp-0.1-0.11.1617svn.el7.noarch
:: [   PASS   ] :: all provides are expected 
:: [   FAIL   ] :: these requires are unexpected: 
:: [   INFO   ] :: /usr/bin/python
:: [   INFO   ] :: python(abi) = 2.7
:: [   LOG    ] :: rh-nodejs4-http-parser
:: [   PASS   ] :: Checking for the presence of rh-nodejs4-http-parser rpm 
:: [   LOG    ] :: Package versions:
:: [   LOG    ] ::   rh-nodejs4-http-parser-2.6.1-1.el7.x86_64
:: [   FAIL   ] :: these provides are unexpected: 
:: [   INFO   ] :: libhttp_parser.so.2()(64bit)
:: [   INFO   ] :: libhttp_parser_strict.so.2()(64bit)
:: [   PASS   ] :: all requires are expected 
:: [   LOG    ] :: rh-nodejs4-http-parser-devel
:: [   PASS   ] :: Checking for the presence of rh-nodejs4-http-parser-devel rpm 
:: [   LOG    ] :: Package versions:
:: [   LOG    ] ::   rh-nodejs4-http-parser-devel-2.6.1-1.el7.x86_64
:: [   PASS   ] :: all provides are expected 
:: [   FAIL   ] :: these requires are unexpected: 
:: [   INFO   ] :: libhttp_parser.so.2()(64bit)
:: [   INFO   ] :: libhttp_parser_strict.so.2()(64bit)
:: [   LOG    ] :: rh-nodejs4-libuv
:: [   PASS   ] :: Checking for the presence of rh-nodejs4-libuv rpm 
:: [   LOG    ] :: Package versions:
:: [   LOG    ] ::   rh-nodejs4-libuv-1.7.5-3.el7.x86_64
:: [   FAIL   ] :: these provides are unexpected: 
:: [   INFO   ] :: libuv.so.1()(64bit)
:: [   FAIL   ] :: these requires are unexpected: 
:: [   INFO   ] :: libnsl.so.1()(64bit)
:: [   LOG    ] :: rh-nodejs4-libuv-devel
:: [   PASS   ] :: Checking for the presence of rh-nodejs4-libuv-devel rpm 
:: [   LOG    ] :: Package versions:
:: [   LOG    ] ::   rh-nodejs4-libuv-devel-1.7.5-3.el7.x86_64
:: [   PASS   ] :: all provides are expected 
:: [   FAIL   ] :: these requires are unexpected: 
:: [   INFO   ] :: libuv.so.1()(64bit)
. . .
:: [   LOG    ] :: rh-nodejs4-nodejs
:: [   PASS   ] :: Checking for the presence of rh-nodejs4-nodejs rpm 
:: [   LOG    ] :: Package versions:
:: [   LOG    ] ::   rh-nodejs4-nodejs-4.3.0-3.el7.x86_64
:: [   PASS   ] :: all provides are expected 
:: [   FAIL   ] :: these requires are unexpected: 
:: [   INFO   ] :: ca-certificates
:: [   INFO   ] :: libnsl.so.1()(64bit)
:: [   INFO   ] :: libuv.so.1()(64bit)
. . .
:: [   LOG    ] :: rh-nodejs4-nodejs-devel
:: [   PASS   ] :: Checking for the presence of rh-nodejs4-nodejs-devel rpm 
:: [   LOG    ] :: Package versions:
:: [   LOG    ] ::   rh-nodejs4-nodejs-devel-4.3.0-3.el7.x86_64
:: [   PASS   ] :: all provides are expected 
:: [   FAIL   ] :: these requires are unexpected: 
:: [   INFO   ] :: libnsl.so.1()(64bit)
:: [   INFO   ] :: libuv.so.1()(64bit)
. . .
:: [   LOG    ] :: rh-nodejs4-runtime
:: [   PASS   ] :: Checking for the presence of rh-nodejs4-runtime rpm 
:: [   LOG    ] :: Package versions:
:: [   LOG    ] ::   rh-nodejs4-runtime-2.2-5.el7.x86_64
:: [   PASS   ] :: all provides are expected 
:: [   FAIL   ] :: these requires are unexpected: 
:: [   INFO   ] :: /usr/bin/scl_source
Comment 3 Tomas Hrcka 2016-04-06 03:12:44 EDT
rh-nodejs4-libuv-1.7.5-8.el7
rh-nodejs4-http-parser-2.6.1-4.el7
Comment 9 errata-xmlrpc 2016-05-31 06:17:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1155

Note You need to log in before you can comment on or make changes to this bug.