Bug 1316643 - Broken symlink pointing to inherits
Broken symlink pointing to inherits
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-nodejs4 (Show other bugs)
rh-nodejs4
Unspecified Unspecified
medium Severity medium
: beta
: 2.2
Assigned To: Zuzana Svetlikova
Miroslav Hradílek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 11:33 EST by Miroslav Hradílek
Modified: 2016-05-31 06:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Symlinks in the chokidar module representing the inherits module point to a corrupted target "inherits@>= 2", which makes the symlinks effectively useless. Consequently, the chokidar module does not work correctly. Additionally, the npm package manager sometimes prints similar error messages, which can be safely ignored.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 06:17:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Hradílek 2016-03-10 11:33:20 EST
Description of problem:
Symlinks in chokidar and npm representing inheritts module are pointing to corrupted target "inherits@>= 2", this makes them effectively useless.

Version-Release number of selected component (if applicable):
rh-nodejs4-npm-2.14.13-9.el7.noarch
rh-nodejs4-nodejs-chokidar-1.4.1-8.el7.noarch


:: [   LOG    ] :: Target /opt/rh/rh-nodejs4/root/usr/lib/node_modules/inherits@>= 2 does not exist
:: [   LOG    ] :: Target /opt/rh/rh-nodejs4/root/usr/lib/node_modules/inherits@>= 2 not from rh-nodejs4\* package
:: [   FAIL   ] :: /opt/rh/rh-nodejs4/root/usr/lib/node_modules/chokidar/node_modules/inherits 
. . .
:: [   LOG    ] :: Target /opt/rh/rh-nodejs4/root/usr/lib/node_modules/inherits@>= 2 does not exist
:: [   LOG    ] :: Target /opt/rh/rh-nodejs4/root/usr/lib/node_modules/inherits@>= 2 not from rh-nodejs4\* package
:: [   FAIL   ] :: /opt/rh/rh-nodejs4/root/usr/lib/node_modules/npm/node_modules/inherits
Comment 4 errata-xmlrpc 2016-05-31 06:17:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1155

Note You need to log in before you can comment on or make changes to this bug.