This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1316649 - search in content hosts throws PG::Error: ERROR: syntax error at or near "OR"
search in content hosts throws PG::Error: ERROR: syntax error at or near "OR"
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Justin Sherrill
Jitendra Yejare
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 11:40 EST by Tom McKay
Modified: 2016-12-12 07:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:05:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[Verified] Screenshot Attached (97.34 KB, image/png)
2016-04-01 10:07 EDT, Jitendra Yejare
no flags Details
[Verified] Screenshot Attached (92.19 KB, image/png)
2016-04-01 10:07 EDT, Jitendra Yejare
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14144 None None None 2016-04-22 12:01 EDT

  None (edit)
Description Tom McKay 2016-03-10 11:40:40 EST
Attempting to search with a value of "virtual" throws an error. Using autocomplete search works, it's just he free form text search that errors.
Comment 1 Tom McKay 2016-03-10 11:40:42 EST
Created from redmine issue http://projects.theforeman.org/issues/14144
Comment 3 Bryan Kearney 2016-03-10 14:09:31 EST
Upstream bug component is WebUI
Comment 4 Bryan Kearney 2016-03-10 16:09:32 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/14144 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello|ab0b78492bdb758cf9d11eb893ba59c9e9759033.
Comment 6 Jitendra Yejare 2016-04-01 06:05:09 EDT
@Tom: May I know the repro steps for this bug.
Comment 7 Jitendra Yejare 2016-04-01 10:07 EDT
Created attachment 1142574 [details]
[Verified] Screenshot Attached
Comment 8 Jitendra Yejare 2016-04-01 10:07 EDT
Created attachment 1142575 [details]
[Verified] Screenshot Attached
Comment 9 Jitendra Yejare 2016-04-01 10:08:09 EDT
Verified this bug in Sat 6.2 snap 6.

I see that the scoped searching the content-host/host actually doesnt throws an error mentioned in description.

The issue is no more reproducible and hence moving to verified.

Verified screenshot attached.
Comment 11 errata-xmlrpc 2016-07-27 05:05:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.