Bug 1316650 - Dashboard - Current Subscription Totals widget calculates subscriptions incorrectly
Dashboard - Current Subscription Totals widget calculates subscriptions incor...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Dashboard (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: David Davis
sthirugn@redhat.com
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 11:41 EST by sthirugn@redhat.com
Modified: 2016-07-27 07:28 EDT (History)
2 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:28:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proof! (35.96 KB, image/png)
2016-06-23 16:10 EDT, Bryan Kearney
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14299 None None None 2016-04-22 12:20 EDT

  None (edit)
Description sthirugn@redhat.com 2016-03-10 11:41:35 EST
Description of problem:
Dashboard - Current Subscription Totals widget calculates subscriptions incorrectly

Version-Release number of selected component (if applicable):
Satellite 6.2.0-beta-snap3

How reproducible:
Always

Steps to Reproduce:
1. Upload a subscription which contains just 'Employee SKU'
2. Navigate to Dashboard -> Current Subscription Totals

Actual results:
Active subscriptions - 2

Expected results:
Active Subscriptions - 1

Additional info:
As per the irc conversation with dev, one theory is that the temporary subscriptions (like guest subscriptions) are automatically counted which is incorrect.
Comment 3 Partha Aji 2016-03-21 11:19:31 EDT
Created redmine issue http://projects.theforeman.org/issues/14299 from this bug
Comment 5 Bryan Kearney 2016-03-21 16:04:15 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14299 has been closed
-------------
David Davis
Applied in changeset commit:katello|44043748957d4a593148e63298faa7e7f529ef86.
Comment 6 Bryan Kearney 2016-06-23 16:10 EDT
Created attachment 1171738 [details]
proof!
Comment 8 Bryan Kearney 2016-07-27 07:28:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.