Bug 1316662 - 'Consumed' field in Activation keys summary page is confusing with 'Consumed' field in Subscriptions
'Consumed' field in Activation keys summary page is confusing with 'Consumed'...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Zach Huntington-Meath
sthirugn@redhat.com
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 12:21 EST by sthirugn@redhat.com
Modified: 2016-07-27 05:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:26:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14146 None None None 2016-04-22 11:45 EDT

  None (edit)
Description sthirugn@redhat.com 2016-03-10 12:21:45 EST
Description of problem:
Activation keys summary page lists 'unlimited' subscriptions when I had just 5 subscriptions

Version-Release number of selected component (if applicable):
Satellite 6.2.0-beta-snap3

How reproducible:
Always

Steps to Reproduce:
1. Create an activation key and attach it to a subscription (say EmployeeSKU of 5 counts)

Actual results:
Go to Content -> Activation Keys and review the summary page:
Consumed column says '0 out of Unlimited'

Expected results:
It should say '0 out of 5'

Additional info:
Comment 2 Brad Buckingham 2016-03-10 13:52:33 EST
Hi Suresh,  the 'Consumed' column on the summary is how many times the activation key has been used by Content Hosts, based upon the Content Host Limit.

Summary:
"0 out of Unlimited"
- 0 == # content hosts
- Unlimited == "Content Host Limit"

We could change the "Consumed" to something else, if it would help (e.g. "Used").

Thoughts?
Comment 3 sthirugn@redhat.com 2016-03-10 14:04:04 EST
I like "Used". But splitting into two columns may be even useful, something like:

Used    Content Host Limit
2             Unlimited
0                5
1                4
Comment 4 Brad Buckingham 2016-03-10 14:38:53 EST
A few of this discussed this in IRC and we aligned on the solution that follows.

In the UI:
- Content -> Activation Keys
  - change "Consumed" to "Host Limit"

- Content -> Activation Keys -> [key] -> Details
  - change "Content Host Limit" to "Host Limit"

In the CLI:
- activation_key info
  - change "Content Host Limit" to "Host Limit"
Comment 5 Zach Huntington-Meath 2016-03-10 15:40:05 EST
Created redmine issue http://projects.theforeman.org/issues/14146 from this bug
Comment 6 Bryan Kearney 2016-03-15 10:08:59 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14146 has been closed
-------------
Zach Huntington-Meath
Applied in changeset commit:hammer-cli-katello|146038b504d950e01a78dd1f11fa9248055a47ee.
Comment 7 sthirugn@redhat.com 2016-03-24 14:42:54 EDT
Verified in Satellite-6.2-beta-snap-5.1

In the UI:
- Content -> Activation Keys
  - changed "Consumed" to "Host Limit"

- Content -> Activation Keys -> [key] -> Details
  - changed "Content Host Limit" to "Host Limit"

also in cli, activation-key info and list are showing Host Limit.

hammer> activation-key list --organization-id=1
---|---------|----------------|-----------------------|-------------
ID | NAME    | HOST LIMIT     | LIFECYCLE ENVIRONMENT | CONTENT VIEW
---|---------|----------------|-----------------------|-------------
1  | rhel7ak | 8 of Unlimited | DEV                   | rhel7cv     
---|---------|----------------|-----------------------|-------------

hammer> activation-key info --id=1
Name:                  rhel7ak
ID:                    1
Description:           
Host Limit:            Unlimited
Auto Attach:           false
Lifecycle Environment: DEV
Content View:          rhel7cv
Host Collections:
Comment 10 errata-xmlrpc 2016-07-27 05:26:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.