Bug 131667 - Own mozilla plugin dir(s)
Summary: Own mozilla plugin dir(s)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: EasyFix, Patch
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-09-02 22:50 UTC by Ville Skyttä
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-05 21:33:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Own Mozilla plugin dir(s) (478 bytes, patch)
2004-09-02 22:51 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2004-09-02 22:50:31 UTC
It would be nice to have kdebase (~ konqueror) to own the mozilla
plugin dirs.

In short: %{_libdir}/mozilla/plugins is the generic location for
mozilla plugins; and plugin packages could have a rpm dependency on
that dir, not a specific browser.  I don't want to have mozilla
installed to be able to use plugins with konqueror...

For more discussion, see bug 131247.  Will attach a suggested patch.

Comment 1 Ville Skyttä 2004-09-02 22:51:52 UTC
Created attachment 103411 [details]
Own Mozilla plugin dir(s)

Comment 2 Ngo Than 2004-09-03 12:21:44 UTC
Ville, it's perhaps better if the plugin package should own the
%{_libdir}/mozilla, %{_libdir}/mozilla/plugins.

Comment 3 Ville Skyttä 2004-09-03 17:30:56 UTC
But that does not help with the initial requirement, it actually would
make it impossible to implement, see bug 131247.

When installing a plugin package, we need a way to specify a
dependency: "this package requires a web browser that loads Mozilla
compatible plugins from $dir".

So a foo-plugin package would have:

   Requires: %{_libdir}/mozilla/plugins

Now, if any _plugin_ package owns that dir, the dependency is not
reliable any more, because it would be satisfied by that plugin, not a
browser.

Comment 4 Ngo Than 2004-09-05 21:33:55 UTC
it's fixed in 3.3.0-2.


Note You need to log in before you can comment on or make changes to this bug.