Bug 1316687 - named's dispatcher for systemd blocks to get NetworkManager to state CONNECTED (boot delay)
named's dispatcher for systemd blocks to get NetworkManager to state CONNECTE...
Status: CLOSED DUPLICATE of bug 1277257
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
23
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Tomáš Hozza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 14:24 EST by Antonin
Modified: 2016-05-12 06:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 06:39:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin 2016-03-10 14:24:38 EST
Description of problem:
During boot process when network interfaces are set up (by NetworkManager) there are started installed dispatchers. For BIND daemon there is a file "/etc/NetworkManager/dispatcher.d/13-named". It contains this command:

/usr/bin/systemctl reload named.service > /dev/null 2>&1 || true

It calls "named.service". But systemd starts "named.service" when "network-online.target" is met. At this time the network is not accessible. So there is 30sec delay and then "NetworkManager-wait-online.service" fail. After that boot process continues.

Version-Release number of selected component (if applicable):
bind-9.10.3-10.P3.fc23.x86_64

How reproducible:
Package "bind" installed.
NetworkManager.service and NetworkManager-dispatcher.service enabled.

Steps to Reproduce:
1. Boot pc
2. Enter command "systemctl" or "journalctl -b"
3. search for NetworkManager-wait-online.service fail

Actual results:
Boot process delay 30 seconds and there is present "NetworkManager-wait-online.service" fail.

Expected results:
Faster boot.

Additional info:
In my environment it helps to use "--no-block" option in dispatcher file. Like this:
/usr/bin/systemctl --no-block reload named.service > /dev/null 2>&1 || true
Comment 1 Tomáš Hozza 2016-05-12 06:39:06 EDT

*** This bug has been marked as a duplicate of bug 1277257 ***

Note You need to log in before you can comment on or make changes to this bug.