Bug 131671 - Kernel panic at boot
Kernel panic at boot
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-09-02 20:30 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-03 21:22:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-09-02 20:30:47 EDT
Description of problem:

  I updated a lot of stuff and kernel 541 and 541smp as well

When I rebooted (541smp), the following appeared on screen
Switching to new root
switchroot - mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing:
        Attempted to kill init!

I then tried 541 plain with the same results.

Then went back to 538smp

eth0 still inactive on boot completion, but
/etc/sysconfig/network-scripts/ifup eth0
will bring it up.

During the 538smp boot, I noticed kudzu complaining - this is probably
fixed in 541 ...

Version-Release number of selected component (if applicable):

kernel ... 541smp and 541 plain

How reproducible:

Both times I tried (once each). Needed to power cycle to recover. (But
it did recover - to an earlier kernel

Steps to Reproduce:
1. boot (as above)
Actual results:

Kernel panic

Expected results:

  successful boot

Additional info:

  Logs? do you need any logs?
Comment 1 Bob Gustafson 2004-09-02 20:47:06 EDT
This is my boot log - not so much has been captured.

Sep  2 19:13:58 hoho2 zebra: zebra shutdown succeeded
Sep  2 19:13:58 hoho2 nfslock: rpc.statd shutdown succeeded
Sep  2 19:13:59 hoho2 portmap: portmap shutdown succeeded
Sep  2 19:14:00 hoho2 syslog: klogd shutdown succeeded

Here is where the kernel panics occurred - below is start of 538smp

Sep  2 19:20:58 hoho2 syslog: syslogd startup succeeded
Sep  2 19:20:58 hoho2 syslog: klogd startup succeeded
Sep  2 19:20:58 hoho2 irqbalance: irqbalance startup succeeded
Sep  2 19:20:58 hoho2 portmap: portmap startup succeeded
Sep  2 19:20:59 hoho2 nfslock: rpc.statd startup succeeded
Comment 2 Bill Nottingham 2004-09-02 22:34:29 EDT
What happens if you downgrade gawk to something other than 3.1.4 and
rebuild your initrd?
Comment 3 Bob Gustafson 2004-09-03 01:54:04 EDT
Wow - I'm up with 541smp

[user1@hoho2 ~]$ cat /proc/version
Linux version 2.6.8-1.541smp (bhcompile@porky.build.redhat.com) (gcc
version 3.4.1 20040831 (Red Hat 3.4.1-10)) #1 SMP Wed Sep 1 18:15:33
EDT 2004
[user1@hoho2 ~]$

---- I did a couple of things, ending up with remaking initrd as Bill

The first thing I did was remember that I had previously moved
/etc/modprobe.conf out of the way. I checked to see if there was a new
version (came in the latest yum upgrade ??). Nope, so I moved the
previously moved aside version back in.

Then I tried to boot 541smp

It still kernel paniced. I wrote down a few more lines from the console:

loading ext3.ko module
Creatng root device
mkrootdev: label /1 not found
Mounting root flesystem
mount: error 2 mounting ext3
mount: error 2 mounting none
Switching to new root

--- then more or less (did not copy down) the lines given in the
beginning of this bug report.

== Then I booted back into 538smp and took a look at the mkinitrd

The version of gawk was 3.1.4-1 - did not look for a lower version,
but thought I would practice mkinitrd step. If I got the same initrd
file as currently, then I would look for a different version of gawk.

I first moved the old /boot/initrd out of the way (extension brok)

Then built a new initrd:

/sbin/mkinitrd /boot/initrd-2.6.8-1.541smp.img 2.6.8-1.541smp

=== Note that listing below shows my new initrd much bigger than the
broken version (3rd line in listing).

So, if it was different, why not try to boot it - and the rest is history.

[root@hoho2 boot]# ls -lt | more
total 47472
-rw-r--r--  1 root root  724061 Sep  3 00:29 initrd-2.6.8-1.541smp.img
drwxr-xr-x  2 root root    1024 Sep  2 18:00 grub
-rw-r--r--  1 root root  580836 Sep  2 17:55 initrd-2.6.8-1.541smp.brok
-rw-r--r--  1 root root  582614 Sep  2 17:47 initrd-2.6.8-1.541.img
-rw-r--r--  1 root root   81860 Sep  2 03:48 memtest86+-1.26
-rw-r--r--  1 root root   49840 Sep  1 17:24 config-2.6.8-1.541smp
-rw-r--r--  1 root root  254083 Sep  1 17:24 System.map-2.6.8-1.541smp
-rw-r--r--  1 root root 1384634 Sep  1 17:24 vmlinuz-2.6.8-1.541smp
-rw-r--r--  1 root root   50385 Sep  1 17:10 config-2.6.8-1.541
-rw-r--r--  1 root root  249580 Sep  1 17:10 System.map-2.6.8-1.541
-rw-r--r--  1 root root 1369750 Sep  1 17:10 vmlinuz-2.6.8-1.541
-rw-r--r--  1 root root  258528 Sep  1 10:45 initrd-2.6.8-1.538.img
-rw-r--r--  1 root root  253747 Sep  1 08:51 initrd-2.6.8-1.538smp.img
-rw-r--r--  1 root root   49840 Aug 31 15:37 config-2.6.8-1.538smp
-rw-r--r--  1 root root 1384609 Aug 31 15:37 vmlinuz-2.6.8-1.538smp
-rw-r--r--  1 root root  254083 Aug 31 15:37 System.map-2.6.8-1.538smp
-rw-r--r--  1 root root 1369778 Aug 31 15:24 vmlinuz-2.6.8-1.538
-rw-r--r--  1 root root   50385 Aug 31 15:24 config-2.6.8-1.538
-rw-r--r--  1 root root  249580 Aug 31 15:24 System.map-2.6.8-1.538
Comment 4 Bob Gustafson 2004-09-03 21:22:05 EDT
As mentioned previously Works for me.

Note You need to log in before you can comment on or make changes to this bug.