Bug 1316721 - Ship AppStream metadata file
Ship AppStream metadata file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gimp-lensfun (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Graham White
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 16:54 EST by Jiri Eischmann
Modified: 2016-03-26 14:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: gimp-lensfun-0.2.3-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 19:53:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gimp-lensfun.metainfo.xml (523 bytes, application/xml)
2016-03-10 16:54 EST, Jiri Eischmann
no flags Details

  None (edit)
Description Jiri Eischmann 2016-03-10 16:54:25 EST
Created attachment 1135053 [details]
gimp-lensfun.metainfo.xml

The package doesn't ship AppStream [1] metadata file, so it doesn't appear in GIMP profile in the default app catalog GNOME Software and is not easily discoverable and installable for users.

I've already filed a bug upstream [2] because it should be ideally included there since it's used across Linux distributions, but unless/until upstream ships it it should be included downstream as the packaging guidelines say [3].

I've created the file for you, see the attachment.

[1] http://www.freedesktop.org/software/appstream/docs/sect-Quickstart-Addons.html
[2] https://github.com/seebk/GIMP-Lensfun/issues/15
[3] https://fedoraproject.org/wiki/Packaging:AppData
Comment 1 Fedora Update System 2016-03-11 09:33:13 EST
gimp-lensfun-0.2.4-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-42b7c1ae9c
Comment 2 Fedora Update System 2016-03-11 09:40:12 EST
gimp-lensfun-0.2.3-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6df1c0a2b4
Comment 3 Fedora Update System 2016-03-11 14:25:16 EST
gimp-lensfun-0.2.4-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-42b7c1ae9c
Comment 4 Fedora Update System 2016-03-12 12:24:54 EST
gimp-lensfun-0.2.3-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6df1c0a2b4
Comment 5 Fedora Update System 2016-03-21 19:53:49 EDT
gimp-lensfun-0.2.3-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2016-03-26 14:12:02 EDT
gimp-lensfun-0.2.4-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.