This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1316735 - ISO provisioning Error on RHEV
ISO provisioning Error on RHEV
Status: CLOSED WORKSFORME
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.6.0
Assigned To: Brandon Dunne
Shveta
catalog:rhev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 18:13 EST by Shveta
Modified: 2016-04-19 13:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 13:53:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (12.24 MB, text/plain)
2016-03-10 18:13 EST, Shveta
no flags Details

  None (edit)
Description Shveta 2016-03-10 18:13:30 EST
Created attachment 1135068 [details]
logs

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a catalog item of type RHEV for ISO provisioning
2. It errors out with below in logs
3.

Actual results:


Expected results:


Additional info:


[----] I, [2016-03-10T17:48:25.950216 #1704:283c8ac]  INFO -- : Q-task_id([service_template_provision_task_144]) <AEMethod check_provisioned> 	vmdb_object_type: service_template_provision_task
[----] I, [2016-03-10T17:48:25.951924 #1704:2843e90]  INFO -- : Q-task_id([service_template_provision_task_144]) <AEMethod check_provisioned> ===========================================
[----] I, [2016-03-10T17:48:25.959890 #1704:2843e90]  INFO -- : Q-task_id([service_template_provision_task_144]) <AEMethod check_provisioned> Service ProvisionCheck returned <error> for state <finished> and status <Error>
[----] I, [2016-03-10T17:48:25.995417 #1704:e85990]  INFO -- : Q-task_id([service_template_provision_task_144]) <AEMethod [/ManageIQ/Service/Provisioning/StateMachines/Methods/check_provisioned]> Ending
[----] I, [2016-03-10T17:48:25.995844 #1704:e85990]  INFO -- : Q-task_id([service_template_provision_task_144]) Method exited with rc=MIQ_OK
[----] I, [2016-03-10T17:48:25.996509 #1704:e85990]  INFO -- : Q-task_id([service_template_provision_task_144]) Followed  Relationship [miqaedb:/Service/Provisioning/StateMachines/Methods/CheckProvisioned#create]
[----] I, [2016-03-10T17:48:25.996693 #1704:e85990]  INFO -- : Q-task_id([service_template_provision_task_144]) Processed  State=[checkprovisioned] with Result=[error]
[----] W, [2016-03-10T17:48:25.996894 #1704:e85990]  WARN -- : Q-task_id([service_template_provision_task_144]) Error in State=[checkprovisioned]
[----] I, [2016-03-10T17:48:25.997526 #1704:e85990]  INFO -- : Q-task_id([service_template_provision_task_144]) In State=[checkprovisioned], invoking [on_error] method=[update_serviceprovision_status(status => 'wrong number of arguments (2 for 0)')]
[----] I, [2016-03-10T17:48:26.004274 #1704:e85990]  INFO -- : Q-task_id([service_template_provision_task_144]) Updated namespace [Service/Provisioning/StateMachines/ServiceProvision_Template/update_serviceprovision_status  ManageIQ/Service/Provisioning/StateMachines]
[----] I, [2016-03-10T17:48:26.017324 #1704:e85990]  INFO -- : Q-task_id([service_template_provision_task_144]) Invoking [inline] method [/ManageIQ/Service/Provisioning/StateMachines/ServiceProvision_Template/update_serviceprovision_status] with inputs [{"status"=>"wrong number of arguments (2 for 0)"}]
[----] I, [2016-03-10T17:48:26.018634 #1704:e85990]  INFO -- : Q-task_id([service_template_provision_task_144]) <AEMethod [/ManageIQ/Service/Provisioning/StateMachines/ServiceProvision_Template/update_serviceprovision_status]> Starting 
[----] I, [2016-03-10T17:48:26.815723 #1704:e85990]  INFO -- : Q-task_id([service_template_provision_task_144]) <AEMethod [/ManageIQ/Service/Provisioning/StateMachines/ServiceProvision_Template/update_serviceprovision_status]> Ending
[----] I, [2016-03-10T17:48:26.816064 #1704:e85990]  INFO -- : Q-task_id([service_template_provision_task_144]) Method exited with rc=MIQ_OK
[----] I, [2016-03-10T17:48:35.517140 #18232:10b998c]  INFO -- : MiqAeEvent.build_evm_event >> event=<:unassigned_company_tag> inputs=<{"MiqEvent::miq_event"=>1060154, :miq_event_id=>1060154, "EventStream::event_stream"=>1060154, :event_stream_id=>1060154}>
[----] I, [2016-03-10T17:48:35.817470 #18232:10b998c]  INFO -- : MiqAeEvent.build_evm_event >> event=<:unassigned_company_tag> inputs=<{"MiqEvent::miq_event"=>1060155, :miq_event_id=>1060155, "EventStream::event_stream"=>1060155, :event_stream_id=>1060155}>
Comment 2 Greg McCullough 2016-03-11 10:46:06 EST
Shveta - This looks like the issue reported here: https://github.com/ManageIQ/manageiq/issues/6939

You did not specify what version you are running but if it is upstream you will want to retest with the latest.
Comment 3 Shveta 2016-03-11 14:57:18 EST
Greg , 

Appliance version is 5.5.2.4.20160127105142_395c086 .
Doesn't look like the same issue to me .

In the github issue .. request was not submitted .
In this issue request is submitted and fails with error.
Comment 4 Greg McCullough 2016-03-11 15:35:44 EST
Thanks, can we work against your appliance to troubleshoot this?
Comment 5 Shveta 2016-03-11 16:34:46 EST
Sure .. https://10.8.199.141
Comment 6 Brandon Dunne 2016-04-18 16:26:34 EDT
Shveta,

I checked out the tag for that version and can't reproduce the issue.  Do you have the evm.log available?  Also, the IP address that you left is no longer responding.
Comment 7 Shveta 2016-04-19 13:53:51 EDT
Not seeing this issue anymore .
Checked in 5.6.0.1-beta2.20160413141124_e25ac0e

Note You need to log in before you can comment on or make changes to this bug.