Bug 131676 - expander is misdrawn
Summary: expander is misdrawn
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 131589
TreeView+ depends on / blocked
 
Reported: 2004-09-03 02:37 UTC by Matthias Clasen
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-08 13:33:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed workaround (604 bytes, patch)
2004-09-04 04:41 UTC, Matthias Clasen
no flags Details | Diff

Description Matthias Clasen 2004-09-03 02:37:59 UTC
the expanded expander is misdrawn. It looks as if the triangle is not
exactly symmetric, causing some ugly aliasing. This is rumoured to be
related to floating point changes in gcc 3.4.1...

Comment 1 Matthias Clasen 2004-09-04 04:39:22 UTC
This really seems to be a compiler issue. Inserting any function call
- even g_free (NULL) - between create_affine() and the loop over the
points in gtk_default_draw_expander() fixes it.



Comment 2 Matthias Clasen 2004-09-04 04:41:42 UTC
Created attachment 103456 [details]
proposed workaround


Note You need to log in before you can comment on or make changes to this bug.