Bug 1316776 - [cachefilesd] TPS fail: postuninstall scriptlet fail
[cachefilesd] TPS fail: postuninstall scriptlet fail
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cachefilesd (Show other bugs)
6.8
All Linux
high Severity high
: rc
: ---
Assigned To: David Howells
Yin.JianHong
: EasyFix, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 22:59 EST by Yin.JianHong
Modified: 2016-05-10 21:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 21:28:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix.patch (425 bytes, patch)
2016-03-10 23:12 EST, Yin.JianHong
no flags Details | Diff

  None (edit)
Description Yin.JianHong 2016-03-10 22:59:57 EST
Description of problem:
doRpmCommand: rpm -e cachefilesd-0.10.2-2.el6.i686 cachefilesd-debuginfo-0.10.2-2.el6.i686
doRpmCommand-result (0): /sbin/restorecon:  lstat(/var/cache/fscache) failed:  No such file or directory

the issue because:
$ rpm -q --scripts -p cachefilesd-0.10.2-2.el6.x86_64.rpm 
postinstall scriptlet (using /bin/sh):
/sbin/chkconfig --add cachefilesd

if [ "$1" -ge 1 ]; then
	/sbin/service cachefilesd condrestart > /dev/null
fi
preuninstall scriptlet (using /bin/sh):
if [ $1 -eq 0 ]; then
	/sbin/service cachefilesd stop
	/sbin/chkconfig --del cachefilesd
fi
postuninstall scriptlet (using /bin/sh):
if [ $1 -eq 0 ]; then
	# Fix up non-standard directory context
	/sbin/restorecon -R /var/cache/fscache || :
               \---> here not check if the dir is exists
fi


Version-Release number of selected component (if applicable):
cachefilesd-0.10.2-2.el6

How reproducible:
100%

Steps to Reproduce:
1. rpm all yum install cachefilesd-0.10.2-2.el6
2. rpm -e cachefilesd-0.10.2-2.el6

Actual results:
when remove package cachefilesd, user get a fail msg

Expected results:
no fail msg if success

Additional info:
Comment 1 Yin.JianHong 2016-03-10 23:12 EST
Created attachment 1135112 [details]
fix.patch
Comment 6 errata-xmlrpc 2016-05-10 21:28:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0975.html

Note You need to log in before you can comment on or make changes to this bug.