Bug 1316805 - [RFE] possibility to control balancing and stickiness options when creating a route
[RFE] possibility to control balancing and stickiness options when creating a...
Status: CLOSED DUPLICATE of bug 1278851
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Mike Barrett
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 03:01 EST by Alexander Koksharov
Modified: 2016-04-14 15:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-14 15:56:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Koksharov 2016-03-11 03:01:30 EST
Description of problem:
"Is there a way to use source IPs as described in the documentation [0]? For example for REST Calls which aren't using cookies this would be good."

For all routes created balancing mechanism is selected as this: 
  clear http -> balance leastconn
  secured connection -> balance source

Sessions stickiness is not configured at all. It would be good to have possibility to control balance method and stickiness options for each route independently.

[0] https://docs.openshift.com/enterprise/3.0/install_config/install/deploy_router.html#using-the-container-network-stack

Version-Release number of selected component (if applicable):
3.1

How reproducible:
NA. hardcoded

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Customer's
Comment 2 Dan McPherson 2016-04-14 15:56:12 EDT

*** This bug has been marked as a duplicate of bug 1278851 ***

Note You need to log in before you can comment on or make changes to this bug.