Bug 1316825 - (CVE-2016-3116) CVE-2016-3116 dropbear: X11 forwarding input not validated properly
CVE-2016-3116 dropbear: X11 forwarding input not validated properly
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20160309,repor...
: Security
Depends On: 1316826 1316827
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 03:57 EST by Andrej Nemec
Modified: 2016-03-11 03:58 EST (History)
3 users (show)

See Also:
Fixed In Version: dropbear 2016.72
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Nemec 2016-03-11 03:57:50 EST
A vulnerability was found in a way dropbear processed X11 forwarding input. By using a specially crafted request, an attacker could bypass the authorized_keys command restrictions.

External references:

https://matt.ucc.asn.au/dropbear/CHANGES

CVE assignment:

http://seclists.org/oss-sec/2016/q1/593
Comment 1 Andrej Nemec 2016-03-11 03:58:33 EST
Created dropbear tracking bugs for this issue:

Affects: fedora-all [bug 1316826]
Affects: epel-all [bug 1316827]

Note You need to log in before you can comment on or make changes to this bug.