Bug 1316854 - [RFE] add possibility to import ova files via rest api /sdk
[RFE] add possibility to import ova files via rest api /sdk
Status: CLOSED DUPLICATE of bug 1346847
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
future
Unspecified Unspecified
unspecified Severity unspecified with 1 vote (vote)
: ---
: ---
Assigned To: Shahar Havivi
Pavel Stehlik
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 05:15 EST by Sven Kieske
Modified: 2016-06-24 06:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-24 06:12:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Sven Kieske 2016-03-11 05:15:12 EST
Description of problem:

since 3.6. it's possible to import OVA files via webadmin, but not via rest-api

Version-Release number of selected component (if applicable):

latest master

How reproducible:

always
Steps to Reproduce:
1.
2.
3.

Actual results:
can't upload ova files via rest

Expected results:

can upload
Additional info:

there's sadly no "product" rest api, I first didn't find that restapi is a component from ovirt-engine.

maybe there should be a component for the api itself?

added bug as requested by juan hernández in this mail:

http://lists.ovirt.org/pipermail/devel/2016-March/012581.html
Comment 1 Tomas Jelinek 2016-06-24 06:12:59 EDT
The 1346847 is a more generic bug which aims to implement the REST support for the virt-v2v => closing this as a duplicate of it.

*** This bug has been marked as a duplicate of bug 1346847 ***

Note You need to log in before you can comment on or make changes to this bug.