Bug 1316873 - EC: Set/unset dirty flag for all the update operations
EC: Set/unset dirty flag for all the update operations
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
mainline
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ashish Pandey
: Triaged
Depends On:
Blocks: 1361513 1377570
  Show dependency treegraph
 
Reported: 2016-03-11 06:09 EST by Ashish Pandey
Modified: 2017-03-06 12:20 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.10.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1361513 1377570 (view as bug list)
Environment:
Last Closed: 2017-03-06 12:20:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ashish Pandey 2016-03-11 06:09:32 EST
Description of problem:

Set/unset dirty flag for all the update operations

If write operation come for a file, set its the dirty flag in preop for that file, perform write and then unset dirty flag in post of if write is successful on all the bricks. 
If any brick goes down during write fop, keep the dirty flag ON and don't unset it in postop. This will trigger heal for the file when the bricks comes up.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-03-15 03:26:03 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#1) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 2 Vijay Bellur 2016-03-16 02:48:54 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#2) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 3 Vijay Bellur 2016-03-21 01:45:56 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#3) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 4 Vijay Bellur 2016-03-21 02:24:13 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#4) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 5 Vijay Bellur 2016-03-21 05:40:30 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#5) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 6 Mike McCune 2016-03-28 18:17:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Vijay Bellur 2016-04-04 04:13:13 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#6) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 8 Vijay Bellur 2016-04-12 13:55:49 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#7) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 9 Vijay Bellur 2016-04-19 16:41:28 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#8) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 10 Vijay Bellur 2016-08-17 08:45:35 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#9) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 11 Vijay Bellur 2016-08-18 04:23:38 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#10) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 12 Worker Ant 2016-08-23 06:00:38 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#11) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 13 Worker Ant 2016-08-30 03:00:32 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#12) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 14 Worker Ant 2016-08-31 08:01:30 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#13) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 15 Worker Ant 2016-09-02 04:32:03 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#14) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 16 Worker Ant 2016-09-03 09:12:29 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#15) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 17 Worker Ant 2016-09-08 09:01:40 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#16) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 18 Worker Ant 2016-09-09 01:55:54 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#17) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 19 Worker Ant 2016-09-09 02:14:12 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#18) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 20 Worker Ant 2016-09-09 09:48:01 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#19) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 21 Worker Ant 2016-09-12 04:50:13 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#20) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 22 Worker Ant 2016-09-14 02:30:41 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#21) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 23 Worker Ant 2016-09-14 22:08:52 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#22) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 24 Worker Ant 2016-09-15 13:31:40 EDT
REVIEW: http://review.gluster.org/13733 (cluster/ec: set/unset dirty flag for data/metadata update) posted (#23) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 25 Worker Ant 2016-09-16 02:26:32 EDT
COMMIT: http://review.gluster.org/13733 committed in master by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 660ca23dee3a0f1a7128d3777589467b27af514b
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Mon Aug 22 16:03:13 2016 +0530

    cluster/ec: set/unset dirty flag for data/metadata update
    
    Currently, for all the update operations, metadata or data,
    we set the dirty flag at the end of the operation only if
    a brick is down. This leads to delay in healing and in some
    cases not at all.
    In this patch we set (+1) the dirty flag
    at the start of the metadata or data update operations and
    after successfull completion of the fop, we unset (-1) it again.
    
    Change-Id: Ide5668bdec7b937a61c5c840cdc79a967598e1e9
    BUG: 1316873
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/13733
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
Comment 26 Shyamsundar 2017-03-06 12:20:01 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.