Bug 1316878 - StandardConfigsXMLValidationUnitTestCase fails with patched EAP
StandardConfigsXMLValidationUnitTestCase fails with patched EAP
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite (Show other bugs)
6.4.7
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ivo Studensky
Peter Mackay
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 06:39 EST by Peter Mackay
Modified: 2016-08-30 04:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-30 04:55:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Mackay 2016-03-11 06:39:09 EST
Description of problem:
StandardConfigsXMLValidationUnitTestCase fails when run with patched EAP 6.4.7.CP.CR2. 

Following tests are affected:
- testHostMaster
- testStandalone
- testHost
- testStandaloneHA
- testHostSlave
- testStandaloneFull
- testDomain

The failures are caused by the addition of jboss-as-config_1_8.xsd. The provided configuration files are still using the older 1_7 version and the tests don't take this possibility into account. This only occurs when running the tests with a patched EAP as the patch can't modify configuration files.


Version-Release number of selected component (if applicable):
6.4.7

How reproducible:
always

Steps to Reproduce:
1. run the testsuite using a patched EAP with -Djboss.dist


Actual results:
Fails of StandardConfigsXMLValidationUnitTestCase

Expected results:
No fails.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.