Bug 1316886 - dnf fails win some operations if locale isn't C (ru_RU.UTF-8).
dnf fails win some operations if locale isn't C (ru_RU.UTF-8).
Status: CLOSED DUPLICATE of bug 1303293
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
24
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 07:09 EST by Peter Lemenkov
Modified: 2016-04-04 05:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-04 05:05:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Lemenkov 2016-03-11 07:09:01 EST
Here is the output in "C" locale:

Auriga ~: LANG=C sudo dnf clean packages
Cleaning repos: updates updates-testing fedora
0 package files removed
Auriga ~: LANG=C sudo dnf clean all
Cleaning repos: updates fedora updates-testing
Cleaning up Everything
Auriga ~:

And here is one in ru_RU.UTF-8:

Auriga ~: LANG=ru_RU_UTF-8 sudo dnf clean packages 2>&1 | fpaste
Uploading (6.2KiB)...
http://paste.fedoraproject.org/337145/69808814/ -> http://paste.fedoraproject.org/337145/69808814
Auriga ~: 

Auriga ~: LANG=ru_RU_UTF-8 sudo dnf clean all 2>&1 | fpaste
Uploading (7.7KiB)...
http://paste.fedoraproject.org/337146/69811614/ -> http://paste.fedoraproject.org/337146/69811614
Auriga ~:
Comment 1 Peter Lemenkov 2016-03-11 07:10:50 EST
Sorry made a typo in two last examples. Here are the proper ones:

Auriga ~: LANG=ru_RU.UTF-8 sudo dnf clean packages 
Сброс источников: updates fedora updates-testing
Traceback (most recent call last):
  File "/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.5/site-packages/dnf/cli/cli.py", line 1095, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.5/site-packages/dnf/cli/commands/clean.py", line 230, in run
    return self.clean(extcmds)
  File "/usr/lib/python3.5/site-packages/dnf/cli/commands/clean.py", line 197, in clean
    pkgcode, pkgresults = _clean_packages(repos)
  File "/usr/lib/python3.5/site-packages/dnf/cli/commands/clean.py", line 114, in _clean_packages
    return _clean_files(repos, exts, 'pkgdir', 'package')
  File "/usr/lib/python3.5/site-packages/dnf/cli/commands/clean.py", line 98, in _clean_files
    return _clean_filelist(filetype, filelist)
  File "/usr/lib/python3.5/site-packages/dnf/cli/commands/clean.py", line 85, in _clean_filelist
    msg %= (removed, filetype)
TypeError: not all arguments converted during string formatting
Auriga ~: LANG=ru_RU.UTF-8 sudo dnf clean all
Сброс источников: updates fedora updates-testing
Очистка всего
Traceback (most recent call last):
  File "/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.5/site-packages/dnf/cli/cli.py", line 1095, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.5/site-packages/dnf/cli/commands/clean.py", line 230, in run
    return self.clean(extcmds)
  File "/usr/lib/python3.5/site-packages/dnf/cli/commands/clean.py", line 184, in clean
    pkgcode, pkgresults = _clean_packages(repos)
  File "/usr/lib/python3.5/site-packages/dnf/cli/commands/clean.py", line 114, in _clean_packages
    return _clean_files(repos, exts, 'pkgdir', 'package')
  File "/usr/lib/python3.5/site-packages/dnf/cli/commands/clean.py", line 98, in _clean_files
    return _clean_filelist(filetype, filelist)
  File "/usr/lib/python3.5/site-packages/dnf/cli/commands/clean.py", line 85, in _clean_filelist
    msg %= (removed, filetype)
TypeError: not all arguments converted during string formatting
Auriga ~:
Comment 2 Igor Gnatenko 2016-04-04 05:05:39 EDT

*** This bug has been marked as a duplicate of bug 1303293 ***

Note You need to log in before you can comment on or make changes to this bug.