Bug 1316917 - Using docker interfaces in rhel distro policy breaks selinux-policy rpm build
Using docker interfaces in rhel distro policy breaks selinux-policy rpm build
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.3
All Linux
high Severity high
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
: Reopened
Depends On: 1304322
Blocks: 1236580
  Show dependency treegraph
 
Reported: 2016-03-11 08:35 EST by Lukas Vrabec
Modified: 2016-11-03 22:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 22:44:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Vrabec 2016-03-11 08:35:35 EST
Description of problem:
During selinux-policy build, there is no docker.if file available in build root so 

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-65.el7

How reproducible:
always


Actual results:
docker interface file is not available during selinux-policy build

Expected results:
docker interface file is available during selinux-policy build

Additional info:
We need to attach docker interface file to distgit before every new build like we do it in Fedora 24 distgit.
Comment 1 Lukas Vrabec 2016-03-11 09:20:30 EST
After discussion with Mirek, we need new userspace for this bug and make some changes also in docker.spec file.
Comment 9 errata-xmlrpc 2016-11-03 22:44:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html

Note You need to log in before you can comment on or make changes to this bug.