Bug 1316918 - SELinux does not allow Prosody to listen on port 5000 for mod_proxy65
SELinux does not allow Prosody to listen on port 5000 for mod_proxy65
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Lukas Vrabec
Jan Zarsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 08:38 EST by Robert Scheck
Modified: 2016-11-03 22:44 EDT (History)
9 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-70.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1322815 (view as bug list)
Environment:
Last Closed: 2016-11-03 22:44:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2016-03-11 08:38:56 EST
Description of problem:
Enabling mod_proxy65 of Prosody according to

  http://prosody.im/doc/modules/mod_proxy65

on the default port 5000 leads to the following errors:

Mar 11 14:08:38 socket  warn    server.lua, [::]:5000: permission denied
Mar 11 14:08:38 portmanager     error   Failed to open server port 5000 on ::, Prosody does not have sufficient privileges to use this port
Mar 11 14:08:38 socket  warn    server.lua, [*]:5000: permission denied
Mar 11 14:08:38 portmanager     error   Failed to open server port 5000 on *, Prosody does not have sufficient privileges to use this port

This issue does not occur with SELinux permissive, however there are also
no AVC denials logged in enforced mode. Given this port is configurable, a
prosody_port_t should be likely introduced to allow binding Prosody to any
port labelled with prosody_port_t (because even standard 5222/5223/5269
ports can be changed, see e.g. http://xmpp.org/rfcs/rfc3920.html).

And given TCP port 5000 is a default port by Prosody, this should be allowed
IMHO by default by the SELinux policy as well.

Version-Release number of selected component (if applicable):
prosody-0.9.10-1.el7.x86_64
selinux-policy-3.13.1-60.el7_2.3.noarch

How reproducible:
Everytime, see above and below.

Actual results:
SELinux does not allow Prosody to listen on port 5000 for mod_proxy65.

Expected results:
SELinux allows Prosody to listen on port 5000 for mod_proxy65.
Comment 1 Robert Scheck 2016-03-11 08:42:49 EST
Ah, now that I opened this bug, I noticed that jabber_interserver_port_t
and jabber_client_port_t exist - but that still leaves the port 5000 thing.
Comment 3 Miroslav Grepl 2016-03-14 04:31:51 EDT
Just to be sure, could you attach AVCs?

Thank you.
Comment 4 Robert Scheck 2016-03-24 19:32:57 EDT
Getting these AVCs required "semodule -DB":

type=AVC msg=audit(1458862295.583:24106): avc:  denied  { name_bind } for  pid=31134 comm="lua" src=5000 scontext=system_u:system_r:prosody_t:s0 tcontext=system_u:object_r:commplex_main_port_t:s0 tclass=tcp_socket
type=SYSCALL msg=audit(1458862295.583:24106): arch=c000003e syscall=49 success=no exit=-13 a0=9 a1=29fc0d0 a2=1c a3=6 items=0 ppid=31133 pid=31134 auid=4294967295 uid=990 gid=987 euid=990 suid=990 fsuid=990 egid=987 sgid=987 fsgid=987 tty=(none) ses=4294967295 comm="lua" exe="/usr/bin/lua" subj=system_u:system_r:prosody_t:s0 key=(null)
type=AVC msg=audit(1458862295.584:24107): avc:  denied  { name_bind } for  pid=31134 comm="lua" src=5000 scontext=system_u:system_r:prosody_t:s0 tcontext=system_u:object_r:commplex_main_port_t:s0 tclass=tcp_socket
type=SYSCALL msg=audit(1458862295.584:24107): arch=c000003e syscall=49 success=no exit=-13 a0=9 a1=29fea90 a2=10 a3=5 items=0 ppid=31133 pid=31134 auid=4294967295 uid=990 gid=987 euid=990 suid=990 fsuid=990 egid=987 sgid=987 fsgid=987 tty=(none) ses=4294967295 comm="lua" exe="/usr/bin/lua" subj=system_u:system_r:prosody_t:s0 key=(null)
Comment 5 Robert Scheck 2016-03-24 19:38:03 EDT
Cross-filed case 01606683 on the Red Hat customer portal.
Comment 9 errata-xmlrpc 2016-11-03 22:44:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html

Note You need to log in before you can comment on or make changes to this bug.