Bug 131694 - Black screen during install FC2 on ACER Altos G310
Black screen during install FC2 on ACER Altos G310
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-03 06:46 EDT by Fred de Brouwer
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 16:38:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file :: /usr/share/system-config-display/xconf.py (14.39 KB, text/plain)
2004-09-09 04:34 EDT, Fred de Brouwer
no flags Details
TAR file containing "grub.conf" and "xorg.conf" files (1.74 KB, application/octet-stream)
2004-09-09 04:42 EDT, Fred de Brouwer
no flags Details
grub.conf boot file (578 bytes, text/plain)
2004-09-14 00:33 EDT, Fred de Brouwer
no flags Details
xorg.conf file (3.18 KB, text/plain)
2004-09-14 00:34 EDT, Fred de Brouwer
no flags Details

  None (edit)
Description Fred de Brouwer 2004-09-03 06:46:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040803 Firefox/0.8

Description of problem:
While starting a graphical installation, which is the default, the
screen turns black and no installation is possible. In this situation
the monitor does not show an out of range information.

The graphical card gets probed as "VESA driver (generic)". The monitor
gets properly probed as "Compaq S700 Color Monitor". At the point
where the graphical screen is started the screen turns black. 

I have tried several boot options:
# linux nofb
# linux skippdcc
# linux resolution=1024x768   (and others)
# linux noapic acpi=off

The text installation does run successfuly, however after a boot the
console is not useable, not even the text-console => ALT+Shift+F[1-6]
The monitor shows an error:  "Signal out of Sync (32,5kHz 40Hz)"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start machine from CD#1 (Fedora FC2)
2.hit enter
3.skip testing the CD

Actual Results:  Always get a black screen.

Expected Results:  It should start with the graphical interface to
continue the graphical installation process. At least the text-console
should be available.

Additional info:
Comment 1 Fred de Brouwer 2004-09-06 02:44:43 EDT
I was able to remotely log into the machine (ssh) and ran the
following command: Xorg -configure

The resulting config file contains weird information:
>>>
Section "Monitor"
        #DisplaySize      330   250     # mm
        Identifier   "Monitor0"
        VendorName   "CPQ"
        ModelName    "COMPAQ S700"
        HorizSync    30.0 - 70.0
        HorizSync    876034368.0 - 0.0         (??)
        VertRefresh  50.0 - 0.0                (??)
        Option      "DPMS"
EndSection
<<<



When running the test: X -xf86config /home/fdb/xorg.conf.new
it complains with:
>>> 
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep  6 08:43:41 2004
(++) Using config file: "/home/fdb/xorg.conf.new"
Parse error on line 51 of section Monitor in file /home/fdb/xorg.conf.new
        The HorizSync keyword must be followed by a list of numbers or
ranges.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found
<<<



Strange thing is that the /etc/X11/xorg.conf - file seems to contain
correct information for the screen:
>>>
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Compaq S700 Color Monitor"
        DisplaySize  330        250
        HorizSync    30.0 - 70.0
        VertRefresh  50.0 - 160.0
        Option      "dpms"
EndSection
<<<
Comment 2 Mike A. Harris 2004-09-09 03:55:12 EDT
Please run the following command:

    system-config-display --reconfig

After this, try to start the X server, and attach your X server
log and config file to the bug report using the bugzilla file
attachment feature.

Thanks in advance.
Comment 3 Fred de Brouwer 2004-09-09 04:34:50 EDT
Created attachment 103626 [details]
file :: /usr/share/system-config-display/xconf.py

This is the file the command "system-config-display --reconfig"
complained about.
Comment 4 Fred de Brouwer 2004-09-09 04:37:09 EDT
I ran the command, it returned this error:

[mail: ~] root# system-config-display --reconfig
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 412, in ?
    hardware_state.merge_into(xconfig)
NameError: name 'hardware_state' is not defined
Comment 5 Fred de Brouwer 2004-09-09 04:42:35 EDT
Created attachment 103627 [details]
TAR file containing "grub.conf" and "xorg.conf" files

The files have been modified; I am not completely sure which part makes it
work, however with these 2 files I got a working graphical environment
(800/600).
Comment 6 Mike A. Harris 2004-09-09 04:55:26 EDT
Please attach non-compressed files so they can be viewed in a web
browser.  Thanks in advance.
Comment 7 Fred de Brouwer 2004-09-14 00:33:51 EDT
Created attachment 103816 [details]
grub.conf boot file

By request the text version of "grub.conf"
Comment 8 Fred de Brouwer 2004-09-14 00:34:46 EDT
Created attachment 103817 [details]
xorg.conf file

By request the text version of xorg.conf
Comment 9 Mike A. Harris 2004-12-03 16:38:22 EST
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core 3, which can be obtained from:

        http://fedora.redhat.com/download

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.