Bug 1316944 - Reduce the number of dynflow actions on a capsule sync
Reduce the number of dynflow actions on a capsule sync
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: John Mitsch
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
Depends On: 1321137
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 08:54 EST by John Mitsch
Modified: 2016-07-27 05:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:27:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first capsule sync run (77.70 KB, image/png)
2016-04-18 11:26 EDT, Kedar Bidarkar
no flags Details
second capsule sync run (47.95 KB, image/png)
2016-04-18 11:27 EDT, Kedar Bidarkar
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13987 None None None 2016-04-22 10:57 EDT

  None (edit)
Description John Mitsch 2016-03-11 08:54:36 EST
Optimizing is needed for a capsule sync, which is updating every distributor and importer for all repositories on a capsule each time. This should be done as needed instead.
Comment 1 John Mitsch 2016-03-11 08:54:38 EST
Created from redmine issue http://projects.theforeman.org/issues/13987
Comment 3 Bryan Kearney 2016-03-18 12:03:55 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/13987 has been closed
-------------
John Mitsch
Applied in changeset commit:katello|19be4a17d5add6785c28c30448ba96ce8624bb0a.
Comment 7 Kedar Bidarkar 2016-04-01 06:11:27 EDT
Can you please provide some verification steps.
Comment 8 John Mitsch 2016-04-01 08:56:43 EDT
Kedar,

Run a capsule sync with yum repos and then run another capsule sync right after that. On the second capsule sync, you shouldn't see any UpdateImporter and RefreshDistributor tasks when you look at the dynflow tasks.

-John
Comment 9 Kedar Bidarkar 2016-04-18 11:23:50 EDT
VERIFIED with sat62-snap8.1

Ran a sync to capsule and then ran another capsule sync just after the previous one.

The second capsule sync does not have UpdateImporter and RefreshDistributor in the plan from the foreman-tasks/dynflow
Comment 10 Kedar Bidarkar 2016-04-18 11:26 EDT
Created attachment 1148241 [details]
first capsule sync run
Comment 11 Kedar Bidarkar 2016-04-18 11:27 EDT
Created attachment 1148242 [details]
second capsule sync run
Comment 13 errata-xmlrpc 2016-07-27 05:27:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.