Bug 1316945 - bld_eprog() signal leak
bld_eprog() signal leak
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: zsh (Show other bugs)
6.7
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Kamil Dudka
Branislav Náter
: OtherQA, Patch, ZStream
Depends On: 1311166
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 08:55 EST by Marcel Kolaja
Modified: 2016-03-22 11:59 EDT (History)
8 users (show)

See Also:
Fixed In Version: zsh-4.3.11-4.el6_7.2
Doc Type: Bug Fix
Doc Text:
Previously, if the zsh process received a signal during the execution of a memory allocation function and the signal handler attempted to allocate or free memory, zsh entered a deadlock and became unresponsive. With this update, signal handlers are no longer enabled while handling the global state of zsh or while using the heap memory allocator, which ensures that the described deadlock no longer occurs.
Story Points: ---
Clone Of: 1311166
Environment:
Last Closed: 2016-03-22 11:59:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Kolaja 2016-03-11 08:55:32 EST
This bug has been copied from bug #1311166 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 9 errata-xmlrpc 2016-03-22 11:59:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0486.html

Note You need to log in before you can comment on or make changes to this bug.