Bug 1316973 - engine-setup fails with "Failed to execute stage 'Transaction setup': dwhd is currently running" when DWH service is actually down
engine-setup fails with "Failed to execute stage 'Transaction setup': dwhd is...
Status: CLOSED DUPLICATE of bug 1286441
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
3.5.6.2
x86_64 Linux
medium Severity low (vote)
: ovirt-3.6.6
: ---
Assigned To: Yedidyah Bar David
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 10:16 EST by Dan Yasny
Modified: 2016-04-04 07:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-04 07:52:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sbonazzo: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
logs from the engine (3.12 MB, application/x-gzip)
2016-03-14 09:40 EDT, Dan Yasny
no flags Details

  None (edit)
Description Dan Yasny 2016-03-11 10:16:40 EST
Description of problem:

[root@rhevm ~]# rhevm-setup 
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-dwh.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging-wsp.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-packaging-rhevm-reports.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20160311155624-laj6s9.log
          Version: otopi-1.3.2 (otopi-1.3.2-1.el6ev)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
         
          Welcome to the RHEV 3.5 setup/upgrade.
          Please read the RHEV 3.5 install guide
          https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html/Installation_Guide/index.html.
          Please refer to the RHEV Upgrade Helper application
          https://access.redhat.com/labs/rhevupgradehelper/ which will guide you in the upgrading process.
          Would you like to proceed? (Yes, No) [Yes]: 
         
          --== PRODUCT OPTIONS ==--
         
         
          --== PACKAGES ==--
         
[ INFO  ] Checking for product updates...
[ INFO  ] No product updates found
         
          --== ALL IN ONE CONFIGURATION ==--
         
         
          --== NETWORK CONFIGURATION ==--
         
          Setup can automatically configure the firewall on this system.
          Note: automatic configuration of the firewall may overwrite current settings.
          Do you want Setup to configure the firewall? (Yes, No) [Yes]: No
         
          --== DATABASE CONFIGURATION ==--
         
          The detected DWH database size is 520 MB.
          Setup can backup the existing database. The time and space required for the database backup depend on its size. This process takes time, and in some cases (for instance, when the size is few GBs) may take several hours to complete.
          If you choose to not back up the database, and Setup later fails for some reason, it will not be able to restore the database and all DWH data will be lost.
          Would you like to backup the existing database before upgrading it? (Yes, No) [Yes]: 
         
          --== OVIRT ENGINE CONFIGURATION ==--
         
          Skipping storing options as database already prepared
         
          --== PKI CONFIGURATION ==--
         
         
          --== APACHE CONFIGURATION ==--
         
         
          --== SYSTEM CONFIGURATION ==--
         
         
          --== MISC CONFIGURATION ==--
         
         
          --== END OF CONFIGURATION ==--
         
[ INFO  ] Stage: Setup validation
          During execution engine service will be stopped (OK, Cancel) [OK]: 
[ INFO  ] Cleaning stale zombie tasks and commands
         
          --== CONFIGURATION PREVIEW ==--
         
          Firewall manager                        : iptables
          Update Firewall                         : False
          Host FQDN                               : rhevm.example.com
          Engine database name                    : engine
          Engine database secured connection      : False
          Engine database host                    : localhost
          Engine database user name               : engine
          Engine database host name validation    : False
          Engine database port                    : 5432
          Engine installation                     : True
          PKI organization                        : maxbetgroup.com
          NFS mount point                         : /var/lib/exports/iso
          DWH installation                        : True
          DWH database name                       : ovirt_engine_history
          DWH database secured connection         : False
          DWH database host                       : localhost
          DWH database user name                  : ovirt_engine_history
          DWH database host name validation       : False
          Backup DWH database                     : True
          DWH database port                       : 5432
          Reports installation                    : True
          Reports database name                   : rhevmreports
          Reports database secured connection     : False
          Reports database host                   : localhost
          Reports database user name              : ovirt_engine_reports
          Reports database host name validation   : False
          Reports database port                   : 5432
          Engine Host FQDN                        : rhevm.example.com
          Configure WebSocket Proxy               : True
         
          Please confirm installation settings (OK, Cancel) [OK]: 
[ INFO  ] Cleaning async tasks and compensations
[ INFO  ] Checking the Engine database consistency
[ INFO  ] Stage: Transaction setup
[ INFO  ] Stopping dwh service
[ INFO  ] Stopping reports service
[ INFO  ] Stopping engine service
[ INFO  ] Stopping ovirt-fence-kdump-listener service
[ INFO  ] Stopping websocket-proxy service
[ ERROR ] dwhd is currently running. Its hostname is rhevm.example.com. Please stop it before running Setup.
[ ERROR ] Failed to execute stage 'Transaction setup': dwhd is currently running
[ INFO  ] Yum Performing yum transaction rollback
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20160311155624-laj6s9.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20160311155739-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed


After some investigation, I found that the DWH service was actually down. After I started it, rhevm-setup went through fine

Version-Release number of selected component (if applicable):

[root@rhevm ~]# rpm -qa |grep engine
rhevm-setup-plugin-ovirt-engine-common-3.5.8-0.1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-3.5.8-0.1.el6ev.noarch
[root@rhevm ~]# rpm -qa |grep ovirt
rhevm-setup-plugin-ovirt-engine-common-3.5.8-0.1.el6ev.noarch
ovirt-host-deploy-1.3.2-1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-3.5.8-0.1.el6ev.noarch
ovirt-host-deploy-java-1.3.2-1.el6ev.noarch
[root@rhevm ~]# rpm -qa |grep rhev
rhevm-log-collector-3.5.4-2.el6ev.noarch
rhevm-websocket-proxy-3.5.8-0.1.el6ev.noarch
rhevm-dbscripts-3.5.8-0.1.el6ev.noarch
rhevm-setup-plugins-3.5.4-1.el6ev.noarch
rhevm-setup-3.5.8-0.1.el6ev.noarch
rhevm-webadmin-portal-3.5.8-0.1.el6ev.noarch
rhevm-spice-client-x86-cab-3.5-3.el6.noarch
rhevm-sdk-python-3.5.6.0-1.el6ev.noarch
rhevm-setup-base-3.5.8-0.1.el6ev.noarch
rhevm-setup-plugin-websocket-proxy-3.5.8-0.1.el6ev.noarch
rhevm-userportal-3.5.8-0.1.el6ev.noarch
rhevm-tools-3.5.8-0.1.el6ev.noarch
rhevm-spice-client-x86-msi-3.5-3.el6.noarch
redhat-support-plugin-rhev-3.5.0-1.el6ev.noarch
rhevm-dwh-3.5.5-1.el6ev.noarch
rhevm-dependencies-3.5.1-1.el6ev.noarch
rhevm-doc-3.5.3-1.el6eng.noarch
rhevm-branding-rhev-3.5.0-4.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-common-3.5.8-0.1.el6ev.noarch
rhevm-reports-setup-3.5.8-1.el6ev.noarch
rhevm-backend-3.5.8-0.1.el6ev.noarch
rhevm-3.5.8-0.1.el6ev.noarch
rhevm-image-uploader-3.5.0-4.el6ev.noarch
rhevm-spice-client-x64-cab-3.5-3.el6.noarch
rhevm-dwh-setup-3.5.5-1.el6ev.noarch
rhev-guest-tools-iso-3.5-14.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-3.5.8-0.1.el6ev.noarch
rhevm-restapi-3.5.8-0.1.el6ev.noarch
rhevm-iso-uploader-3.5.1-1.el6ev.noarch
rhevm-spice-client-x64-msi-3.5-3.el6.noarch
rhevm-lib-3.5.8-0.1.el6ev.noarch
rhevm-extensions-api-impl-3.5.8-0.1.el6ev.noarch
rhevm-cli-3.5.0.6-1.el6ev.noarch
rhevm-reports-3.5.8-1.el6ev.noarch


How reproducible:
always

Steps to Reproduce:
1. stop/kill DWH
2. run rhevm-setup
3.

Actual results:
see above

Expected results:
if DWH is stopped, move on, or start it and then try to stop it.

Additional info:
Comment 1 Yedidyah Bar David 2016-03-13 04:03:12 EDT
Please see bug 1216125. Can you check if you are affected by bug 1024028? Please attach all relevant logs, including engine, dwh and postgresql. Thanks.
Comment 2 Dan Yasny 2016-03-14 09:40:01 EDT
This setup has been updated consistently since 2.2, so it might carry bugs if they hadn't been fixed by an upgrade. Not sure how I can verify this though...

Attaching the engine logs
Comment 3 Dan Yasny 2016-03-14 09:40 EDT
Created attachment 1136157 [details]
logs from the engine
Comment 4 Yedidyah Bar David 2016-04-04 05:54:10 EDT
Please attach also yum.log. Thanks.
Comment 5 Dan Yasny 2016-04-04 07:40:19 EDT
I do not have the setup anymore, you will have to get QE to reproduce this one
Comment 6 Yedidyah Bar David 2016-04-04 07:52:32 EDT
OK, closing as duplicate. See also comment 1.

*** This bug has been marked as a duplicate of bug 1024028 ***
Comment 7 Yedidyah Bar David 2016-04-04 07:54:14 EDT
Sorry, changing to a more likely duplicate.

*** This bug has been marked as a duplicate of bug 1286441 ***

Note You need to log in before you can comment on or make changes to this bug.