Bug 1316983 - engine-setup will not be able to rolllback because rhevm-spice-client was not found in enabled repos
engine-setup will not be able to rolllback because rhevm-spice-client was not...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: releng (Show other bugs)
3.6.0
All Linux
high Severity high
: ovirt-3.6.5
: 3.6.5
Assigned To: Joey Boggs
Entitlement Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 11:00 EST by Matthew Davis
Modified: 2016-04-18 03:54 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-18 03:05:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Rel-Eng
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Davis 2016-03-11 11:00:39 EST
Description of problem:

During the upgrade from 3.5.8 -> 3.6.0 using a satellite6 I hit the following error during the engie-setup

"		  Setup will not be able to rollback new packages in case of a failure, because the following installed packages were not found in enabled repositories:
         
		  rhevm-spice-client-x86-cab-3.5-3.el6.noarch
		  rhevm-spice-client-x64-cab-3.5-3.el6.noarch
		  rhevm-spice-client-x86-msi-3.5-3.el6.noarch
		  rhevm-spice-client-x64-msi-3.5-3.el6.noarch
		  Do you want to abort Setup? (Yes, No) [Yes]: "

Additional Info:

Here are the rhev* RPMs installed at time of exectuion of rhev-engine:

rhevm-restapi-3.5.8-0.1.el6ev.noarch
rhevm-setup-base-3.6.3.4-0.1.el6.noarch
rhevm-sdk-python-3.5.6.0-1.el6ev.noarch
rhevm-spice-client-x64-msi-3.5-3.el6.noarch
rhevm-userportal-3.5.8-0.1.el6ev.noarch
rhevm-setup-plugin-websocket-proxy-3.6.3.4-0.1.el6.noarch
rhevm-guest-agent-common-1.0.10-2.el6ev.noarch
rhevm-tools-3.5.8-0.1.el6ev.noarch
rhevm-3.5.8-0.1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-3.6.3.4-0.1.el6.noarch
rhevm-dependencies-3.5.1-1.el6ev.noarch
rhevm-iso-uploader-3.5.1-1.el6ev.noarch
rhevm-spice-client-x86-msi-3.5-3.el6.noarch
rhevm-cli-3.5.0.6-1.el6ev.noarch
rhevm-extensions-api-impl-3.5.8-0.1.el6ev.noarch
rhevm-backend-3.5.8-0.1.el6ev.noarch
rhevm-dbscripts-3.5.8-0.1.el6ev.noarch
rhevm-lib-3.6.3.4-0.1.el6.noarch
rhevm-setup-plugins-3.6.3-1.el6ev.noarch
rhevm-image-uploader-3.5.0-4.el6ev.noarch
rhevm-spice-client-x64-cab-3.5-3.el6.noarch
rhevm-websocket-proxy-3.5.8-0.1.el6ev.noarch
rhevm-setup-3.6.3.4-0.1.el6.noarch
rhevm-branding-rhev-3.5.0-4.el6ev.noarch
rhevm-webadmin-portal-3.5.8-0.1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-common-3.6.3.4-0.1.el6.noarch
rhevm-doc-3.5.3-1.el6eng.noarch
rhevm-log-collector-3.5.4-2.el6ev.noarch
rhevm-spice-client-x86-cab-3.5-3.el6.noarch

And here's the enabled repos:

Loaded plugins: product-id, subscription-manager, versionlock
repo id                                repo name                          status
jb-eap-6-for-rhel-6-server-rpms        JBoss Enterprise Application Platf  2,598
rhel-6-server-rhevm-3.5-rpms           Red Hat Enterprise Virtualization     267
rhel-6-server-rhevm-3.6-rpms           Red Hat Enterprise Virtualization      74
rhel-6-server-rpms                     Red Hat Enterprise Linux 6 Server  16,506
rhel-6-server-satellite-tools-6.1-rpms Red Hat Satellite Tools 6.1 (for R     84
rhel-6-server-supplementary-rpms       Red Hat Enterprise Linux 6 Server     594
repolist: 20,123
Comment 1 Matthew Davis 2016-03-11 11:03:41 EST
I simply answered no and it proceeded. I also checked if the installed packages were avialable in the satellite, and they were.
Comment 3 Matthew Davis 2016-03-21 12:27:15 EDT
Unfortunately I am not. We progressed past this step. I do have another environment I will be upgrading hopefully within 2 months.
Comment 10 Gil Klein 2016-04-18 03:05:05 EDT
Please re-open if you are able to reproduce. See comment #6

Note You need to log in before you can comment on or make changes to this bug.