Bug 1316986 - hammer-cli-csv - add hidden attribute to unsupported sub-commands and options
hammer-cli-csv - add hidden attribute to unsupported sub-commands and options
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Uncategorized (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: Tom McKay
jcallaha
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 11:16 EST by Tom McKay
Modified: 2016-07-27 07:24 EDT (History)
5 users (show)

See Also:
Fixed In Version: rubygem-hammer_cli_csv-2.0.0.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:24:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14162 None None None 2016-04-22 12:50 EDT

  None (edit)
Description Tom McKay 2016-03-11 11:16:48 EST
As a first step to productizing hammer-cli-csv, options and sub-commands that are not fully complete or ready to be supported need to be removed or otherwise hidden.
Comment 1 Tom McKay 2016-03-11 11:16:50 EST
Created from redmine issue http://projects.theforeman.org/issues/14162
Comment 2 Tom McKay 2016-03-11 11:16:54 EST
Upstream bug assigned to tomckay@redhat.com
Comment 4 Bryan Kearney 2016-04-11 12:12:28 EDT
Upstream bug component is Uncategorized
Comment 5 Bryan Kearney 2016-04-11 14:12:03 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14162 has been closed
-------------
Thomas McKay
Applied in changeset commit:hammer-cli-csv|677d03948de8bcc6cef14afe5683d90008c3e45c.
Comment 6 jcallaha 2016-06-16 11:57:35 EDT
Can you provide some rough verification advice/steps?
Comment 7 Tom McKay 2016-07-18 13:27:54 EDT
"hammer csv --help" should show only a reduced set of subcommands: import, export, and settings. Other options are hidden though still accessible if known.
Comment 8 jcallaha 2016-07-18 13:41:13 EDT
Verified in Satellite 6.2 beta Snap 20.2

[root@rhsm-qe-1 ~]# hammer csv --help
Usage:
    hammer csv [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
 SUBCOMMAND                    subcommand
 [ARG] ...                     subcommand arguments

Subcommands:
 export                        export into directory
 import                        import by directory
 settings                      import or export settings

Options:
 -h, --help                    print help
Comment 9 Bryan Kearney 2016-07-27 07:24:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.