Bug 1317054 - Looks like Rally can't connect to it's DB.
Looks like Rally can't connect to it's DB.
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-rally (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: RHOS Maint
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 14:52 EST by Gonéri Le Bouder
Modified: 2016-05-31 11:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-12 13:20:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gonéri Le Bouder 2016-03-11 14:52:19 EST
Description of problem:

Looks like rally is broken.

Run:
rally deployment create --fromenv --name=existing

Version-Release number of selected component (if applicable):

openstack-rally-0.1.1-4.2.el7ost.noarch

How reproducible:

[root@undercloud ~]# rally deployment create --fromenv --name=existing
(sqlite3.OperationalError) no such table: deployments [SQL: u'INSERT INTO deployments (created_at, updated_at, uuid, parent_uuid, name, started_at, completed_at, config, admin, users, enum_deployments_status) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)'] [parameters: ('2016-03-11 19:45:41.462014', '2016-03-11 19:45:41.462032', 'c3ffc8d1-f51e-4e58-8dfb-dfb3a14c1d70', None, u'existing', None, None, '{"admin": {"username": "admin", "tenant_name": "admin", "password": "e3mhr7Fj7ap7PwReuMQekRdGs"}, "type": "ExistingCloud", "endpoint": null, "auth_url": "http://192.0.2.51:5000/v2.0"}', None, <read-only buffer for 0x4541f90, size -1, offset 0 at 0x4552930>, 'deploy->init')]
Looks like Rally can't connect to it's DB.
Make a sure that connection string in rally.conf is proper:
sqlite:////tmp/rally.sqlite

I try as stack user and as root user.
Comment 2 Gonéri Le Bouder 2016-05-18 14:27:17 EDT
The solution is to run first: rally-manage db recreate

Note You need to log in before you can comment on or make changes to this bug.