Bug 1317074 - "No route matches" error when clicking on "Provisioned VMs" link in Provision Request details screen
"No route matches" error when clicking on "Provisioned VMs" link in Provision...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Milan Zazrivec
Shveta
ui:service
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 16:40 EST by Greg McCullough
Modified: 2016-06-29 11:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:42:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Provision Request details screen (100.70 KB, image/png)
2016-03-11 16:43 EST, Greg McCullough
no flags Details
Error screenshot (68.02 KB, image/png)
2016-03-11 16:43 EST, Greg McCullough
no flags Details

  None (edit)
Description Greg McCullough 2016-03-11 16:40:48 EST
Description of problem: After successfully provisioning a VM and viewing the details of the request the # after "Provisioned VMs" is a link which fails with a "No route matches" error.


Version-Release number of selected component (if applicable): 5.5


How reproducible: Always


Steps to Reproduce:
1. Successfully provision a VM
2. Click on request Under Services -> Request to view request details
3. Click on number displayed after "Provisioned VMs" (See attached screenshot)

Actual results:
Error screen is displayed with:
No route matches {:action=>"show/837", :controller=>"miq_request", :id=>"837", :sort_choice=>"Status"} [miq_request/show]

Expected results:
See list of provisioned VMs
Comment 2 Greg McCullough 2016-03-11 16:43 EST
Created attachment 1135416 [details]
Provision Request details screen
Comment 3 Greg McCullough 2016-03-11 16:43 EST
Created attachment 1135417 [details]
Error screenshot
Comment 4 Harpreet Kataria 2016-03-14 09:13:59 EDT
Milan,

Can you look into this one, looks like action is incorrect in the transaction has id included in it, causing routing error. Let me know if you have questions.

Thanks,
~Harpreet
Comment 5 Milan Zazrivec 2016-04-11 14:30:43 EDT
https://github.com/ManageIQ/manageiq/pull/7875
Comment 6 CFME Bot 2016-04-19 13:15:54 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/80fb6f247aa2c71221f24a126e6565d580802ee0

commit 80fb6f247aa2c71221f24a126e6565d580802ee0
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Mon Apr 11 20:27:09 2016 +0200
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Mon Apr 11 20:30:05 2016 +0200

    Fix action_url for gtl view showing provisioned vms
    
    This is to fix the following error thrown by link_to():
    
    No route matches {:action=>"show/10000000000272",
    :controller=>"miq_request", :id=>"10000000000272",
    :sort_choice=>"Status"}
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1317074

 app/views/miq_request/_provisions.html.haml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 7 Shveta 2016-04-22 18:19:48 EDT
Fixed.
Verified in 
5.6.0.4-beta2.3.20160421172650_719e256
Comment 9 errata-xmlrpc 2016-06-29 11:42:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.