Bug 1317086 - rhel-osp-director: undercloud deployment with ssl fails.
rhel-osp-director: undercloud deployment with ssl fails.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Emilien Macchi
Alexander Chuzhoy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 17:59 EST by Alexander Chuzhoy
Modified: 2016-04-15 10:31 EDT (History)
8 users (show)

See Also:
Fixed In Version: instack-undercloud-2.2.6-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-15 10:31:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 291292 None None None 2016-03-11 18:00 EST

  None (edit)
Description Alexander Chuzhoy 2016-03-11 17:59:04 EST
rhel-osp-director: undercloud deployment with ssl fails.

Environment:
instack-undercloud-2.2.5-1.el7ost.noarch

Steps to reproduce:
1. Enable ssl in undercloud.conf
2. run "openstack undercloud install"
Result:

Notice: /Stage[main]/Main/File[/etc/keystone/ssl/certs/signing_cert.pem]/content: content changed '{md5}933adc5e2a6581080c475204a76629f4' to '{md5}a2897b72853752107c86a46dbacaff0c'
Error: Could not start Service[httpd]: Execution of '/bin/systemctl start httpd' returned 1: Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
Wrapped exception:
Execution of '/bin/systemctl start httpd' returned 1: Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
Error: /Stage[main]/Apache::Service/Service[httpd]/ensure: change from stopped to running failed: Could not start Service[httpd]: Execution of '/bin/systemctl start httpd' returned 1: Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
Notice: /Stage[main]/Apache::Service/Service[httpd]: Triggered 'refresh' from 3 events
Notice: /Stage[main]/Keystone/Anchor[keystone_started]: Dependency Service[httpd] has failures: true
Warning: /Stage[main]/Keystone/Anchor[keystone_started]: Skipping because of failed dependencies
Notice: Puppet::Provider::Openstack: user service is unavailable. Will retry for up to 9 seconds.
....
....
+ rc=6
+ set -e
+ echo 'puppet apply exited with exit code 6'
puppet apply exited with exit code 6
+ '[' 6 '!=' 2 -a 6 '!=' 0 ']'
+ exit 6
[2016-03-11 17:46:57,754] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 6]

[2016-03-11 17:46:57,754] (os-refresh-config) [ERROR] Aborting...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 807, in install
    _run_orc(instack_env)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 691, in _run_orc
    _run_live_command(args, instack_env, 'os-refresh-config')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 366, in _run_live_command
    raise RuntimeError('%s failed. See log for details.' % name)
RuntimeError: os-refresh-config failed. See log for details.
Command 'instack-install-undercloud' returned non-zero exit status 1


Expected results:
Successfull undercloud installation.
Comment 5 Alexander Chuzhoy 2016-04-07 19:37:57 EDT
Verified:

Environment:
instack-undercloud-2.2.7-4.el7ost.noarch


The issue doesn't reproduce.
Comment 7 errata-xmlrpc 2016-04-15 10:31:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0637.html

Note You need to log in before you can comment on or make changes to this bug.