Bug 1317087 - [abrt] hamster-time-tracker: module.py:137:__getattr__:AttributeError: 'gi.repository.Gtk' object has no attribute 'TARGET_SAME_APP'
[abrt] hamster-time-tracker: module.py:137:__getattr__:AttributeError: 'gi.re...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hamster-time-tracker (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:7bb8c5acf308eda3402bac183f2...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 18:03 EST by Brandon J. Wyman
Modified: 2016-04-02 16:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: hamster-time-tracker-2.0-0.7.rc1.fc23 hamster-time-tracker-2.0-0.7.rc1.fc24 hamster-time-tracker-2.0-0.8.rc1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:10:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (791 bytes, text/plain)
2016-03-11 18:03 EST, Brandon J. Wyman
no flags Details
File: environ (632 bytes, text/plain)
2016-03-11 18:03 EST, Brandon J. Wyman
no flags Details

  None (edit)
Description Brandon J. Wyman 2016-03-11 18:03:33 EST
Description of problem:
Viewing preferences, trying to move Unsorted item to a specified category.

Version-Release number of selected component:
hamster-time-tracker-2.0-0.3.rc1.fc23

Additional info:
reporter:       libreport-2.6.4
cmdline:        python2 /usr/bin/hamster-windows-service
dso_list:       python-gobject-base-3.18.2-1.fc23.x86_64
executable:     /usr/bin/hamster-windows-service
kernel:         4.4.4-301.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
module.py:137:__getattr__:AttributeError: 'gi.repository.Gtk' object has no attribute 'TARGET_SAME_APP'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/hamster/preferences.py", line 268, in on_category_list_drag_motion
    drop_yes = ("drop_yes", gtk.TARGET_SAME_APP, 0)
  File "/usr/lib64/python2.7/site-packages/gi/overrides/__init__.py", line 39, in __getattr__
    return getattr(self._introspection_module, name)
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 137, in __getattr__
    self.__name__, name))
AttributeError: 'gi.repository.Gtk' object has no attribute 'TARGET_SAME_APP'

Local variables in innermost frame:
info: None
self: <IntrospectionModule 'Gtk' from '/usr/lib64/girepository-1.0/Gtk-3.0.typelib'>
name: 'TARGET_SAME_APP'
Comment 1 Brandon J. Wyman 2016-03-11 18:03:38 EST
Created attachment 1135444 [details]
File: backtrace
Comment 2 Brandon J. Wyman 2016-03-11 18:03:39 EST
Created attachment 1135445 [details]
File: environ
Comment 3 Raphael Groner 2016-03-12 11:07:57 EST
This bug may be somehow related to a missing dependency to pygobject3 as reported in bug #1316230.
Comment 4 Ankur Sinha (FranciscoD) 2016-03-12 11:43:13 EST
Hrm, not so sure about that - from what I find on Google, it seems to be something to do with the difference in the gtk version that the app was developed for, and the version we've got in Fedora.
Comment 5 Raphael Groner 2016-03-12 12:02:03 EST
(In reply to Ankur Sinha (FranciscoD) from comment #4)
> Hrm, not so sure about that - from what I find on Google, it seems to be
> something to do with the difference in the gtk version that the app was
> developed for, and the version we've got in Fedora.

If that's really the case, we've obviously to think about to retire this package. Upstream does not show any progress with development for current versions of Gtk, neither a Python3 port that's also "in progress" since 2014 …
Comment 6 Felix Schwarz 2016-03-12 12:19:19 EST
(In reply to Ankur Sinha (FranciscoD) from comment #4)
> Hrm, not so sure about that - from what I find on Google, it seems to be
> something to do with the difference in the gtk version that the app was
> developed for, and the version we've got in Fedora.

Would you mind filing a bug report upstream (https://github.com/projecthamster/hamster/issues ?). This is a pretty simple oversight I think.

Some of it was already ported ( https://github.com/projecthamster/hamster/blob/master/src/hamster/preferences.py#L86 ) but they missed on place. The GTK3 code should be "gtk.TargetFlags.SAME_APP".
Comment 7 Ankur Sinha (FranciscoD) 2016-03-12 12:26:40 EST
https://github.com/projecthamster/hamster/issues/306
Comment 8 Raphael Groner 2016-03-12 12:59:40 EST
I'm already working on this bug.
Comment 9 Fedora Update System 2016-03-12 13:48:28 EST
hamster-time-tracker-2.0-0.7.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8d09c09ea
Comment 10 Fedora Update System 2016-03-12 13:48:48 EST
hamster-time-tracker-2.0-0.7.rc1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-211cb25c0d
Comment 11 Fedora Update System 2016-03-12 13:50:09 EST
hamster-time-tracker-2.0-0.7.rc1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1b469d9a2d
Comment 12 Fedora Update System 2016-03-13 21:20:12 EDT
hamster-time-tracker-2.0-0.7.rc1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8d09c09ea
Comment 13 Fedora Update System 2016-03-15 14:50:11 EDT
hamster-time-tracker-2.0-0.7.rc1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1b469d9a2d
Comment 14 Fedora Update System 2016-03-15 15:22:17 EDT
hamster-time-tracker-2.0-0.7.rc1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-211cb25c0d
Comment 15 Fedora Update System 2016-03-21 15:55:06 EDT
hamster-time-tracker-2.0-0.8.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-27b68e1fe5
Comment 16 Fedora Update System 2016-03-22 17:26:19 EDT
hamster-time-tracker-2.0-0.8.rc1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-27b68e1fe5
Comment 17 Fedora Update System 2016-03-22 17:40:31 EDT
hamster-time-tracker-2.0-0.7.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8d09c09ea
Comment 18 Fedora Update System 2016-03-23 18:27:28 EDT
hamster-time-tracker-2.0-0.7.rc1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2016-03-25 09:30:38 EDT
hamster-time-tracker-2.0-0.8.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-27b68e1fe5
Comment 20 Fedora Update System 2016-03-25 19:48:36 EDT
hamster-time-tracker-2.0-0.8.rc1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-27b68e1fe5
Comment 21 Fedora Update System 2016-03-26 14:10:39 EDT
hamster-time-tracker-2.0-0.7.rc1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2016-04-02 16:18:46 EDT
hamster-time-tracker-2.0-0.8.rc1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.