This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1317088 - REST API guide missing from Configure / About
REST API guide missing from Configure / About
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
All All
unspecified Severity urgent
: GA
: 5.6.0
Assigned To: Gregg Tanzillo
Taras Lehinevych
doc
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 18:05 EST by Kevin Morey
Modified: 2016-08-02 21:32 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.6.0.12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:42:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Missing API Guide screenshots (134.71 KB, application/pdf)
2016-03-11 18:05 EST, Kevin Morey
no flags Details

  None (edit)
Description Kevin Morey 2016-03-11 18:05:54 EST
Created attachment 1135446 [details]
Missing API Guide screenshots

Description of problem:
The REST API guide is missing from the appliance. It was there in 5.4.3 no it is gone. This is a critical document that customers and developers need access to. Especially during a POC. Please put this back in as soon as possible.

Version-Release number of selected component (if applicable):
5.5.2.4

How reproducible:
100%

Steps to Reproduce:
1. Login as Admin
2. Navigate to Configure / About
3.

Actual results:
REST API guide is no longer there

Expected results:
expected to see the doc there on the appliance.

Additional info:
Just to make sure I checked /var/www/miq/vmdb/public/doc

# ls -lart
total 9364
-rw-r--r--.  1 root root 1398865 Jan 27 13:19 virtual_machines_hosts.pdf
-rw-r--r--.  1 root root  506474 Jan 27 13:19 scripting_actions.pdf
-rw-r--r--.  1 root root  769709 Jan 27 13:19 providers.pdf
-rw-r--r--.  1 root root 1201317 Jan 27 13:19 monitoring_alerts_reporting.pdf
-rw-r--r--.  1 root root  349043 Jan 27 13:19 methods_for_automation.pdf
-rw-r--r--.  1 root root 2294935 Jan 27 13:19 infrastructure_inventory.pdf
-rw-r--r--.  1 root root 1869410 Jan 27 13:19 general_configuration.pdf
-rw-r--r--.  1 root root 1174024 Jan 27 13:19 defining_policies_profiles.pdf
drwxr-xr-x.  2 root root    4096 Jan 28 15:48 .
drwxr-xr-x. 10 root root    4096 Mar 10 10:33 ..

and it is indeed missing from the appliance.

Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information:
Comment 2 Lucy Bopf 2016-05-16 01:56:57 EDT
Hi Kevin,

My apologies for the delay. I'm moving this bug over to the team that maintains the appliance, so we can discuss including the REST API guide in the product.

For your reference, the updated REST API Guide is available at https://access.redhat.com/documentation/en/red-hat-cloudforms/version-4.0/red-hat-cloudforms-rest-api/ as well.
Comment 7 Satoe Imaishi 2016-06-27 11:07:08 EDT
API guide was added in 5.6.0.12 build.
Comment 8 Pete Savage 2016-06-27 13:27:18 EDT
Verified in 5.6.0.13
Comment 10 errata-xmlrpc 2016-06-29 11:42:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.