Bug 1317107 - [RFE] CLI - As a user I want to be able to view ostree info
[RFE] CLI - As a user I want to be able to view ostree info
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: David Davis
Sachin Ghai
http://projects.theforeman.org/issues...
: FutureFeature, Triaged
Depends On:
Blocks: 1321771
  Show dependency treegraph
 
Reported: 2016-03-11 20:04 EST by Partha Aji
Modified: 2016-07-27 05:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:27:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 10074 None None None 2016-04-22 11:14 EDT

  None (edit)
Description Partha Aji 2016-03-11 20:04:27 EST

    
Comment 1 Partha Aji 2016-03-11 20:04:29 EST
Created from redmine issue http://projects.theforeman.org/issues/10074
Comment 2 Partha Aji 2016-03-11 20:04:32 EST
Upstream bug assigned to daviddavis@redhat.com
Comment 3 Bryan Kearney 2016-03-11 22:08:37 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/10074 has been closed
-------------
David Davis
Applied in changeset commit:hammer-cli-katello|50cfe5a818bb7b1f7ac1cc737be1d78c4e10438b.
Comment 5 Sachin Ghai 2016-03-29 05:08:13 EDT
Verified with Sat6.2 beta snap5.1

ostree info is available in 3 different places.

1) ostree tree info associated to Content-view. can be viewed like:

~]# hammer -u admin -p changeme content-view info --id 4 --organization-id 1
Warning: Option --id is deprecated. This option will be removed in Katello 2.5, Use --uuid
ID:                     4
Name:                   cv_ostree
Label:                  cv_ostree
Composite:              false
Description:            
Content Host Count:     0
Organization:           Default Organization
Yum Repositories:       

Docker Repositories:    

OSTree Repositories:    
 1) ID:    25
    Name:  Red Hat Enterprise Linux Atomic Host Trees
    Label: Red_Hat_Enterprise_Linux_Atomic_Host_Trees
Puppet Modules:
Comment 7 Sachin Ghai 2016-03-29 05:11:17 EDT
hammer -u admin -p changeme ostree-branch --help
Usage:
    hammer ostree-branch [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
 SUBCOMMAND                    subcommand
 [ARG] ...                     subcommand arguments

Subcommands:
 info                          Show an ostree branch
 list                          List ostree_branches



Currently, due to some issue, I'm not able to view ostree-branches after sync. So holding the bz verification.
Comment 9 Sachin Ghai 2016-03-31 04:50:01 EDT
I can see ostree branch count under repository info page:

~]# hammer -u admin -p changeme repository info --organization-id 1 --id 8 --product ostree
ID:                 8
Name:               f23_ostree
Label:              f23_ostree
Organization:       Default Organization
Red Hat Repository: no
Content Type:       ostree
URL:                https://dl.fedoraproject.org/pub/fedora/linux/atomic/23/
Publish Via HTTP:   no
Published At:       https://cloud-qe-15.idmqe.lab.eng.bos.redhat.com/pulp/ostree/web/Default_Organization-ostree-f23_ostree
Relative Path:      Default_Organization/Library/custom/ostree/f23_ostree
Product:            
    ID:   7
    Name: ostree
GPG Key:            

Sync:               
    Status:         Success
    Last Sync Date: 21 minutes
Created:            2016/03/31 08:13:53
Updated:            2016/03/31 08:13:55
Content Counts:     
    OSTree Branches: 2
Comment 10 Sachin Ghai 2016-03-31 04:51:22 EDT
[root@cloud-qe-15 ~]# hammer -u admin -p changeme ostree-branch list
---|----------------------------------------------|--------
ID | NAME                                         | VERSION
---|----------------------------------------------|--------
2  | fedora-atomic/f23/x86_64/testing/docker-host | 23.94  
1  | fedora-atomic/f23/x86_64/docker-host         | 23.92  
---|----------------------------------------------|--------
[


[root@cloud-qe-15 ~]# hammer -u admin -p changeme ostree-branch info --id 2
ID:      2
Name:    fedora-atomic/f23/x86_64/testing/docker-host
Version: 23.94
Commit:  5089ab2e1ff5c9a57ad5dc823ee41679d122704b2590a51c1483b7c7730e0b7a
Date:    2016-03-31 08:23:39 UTC
Comment 11 Sachin Ghai 2016-03-31 05:52:59 EDT
So based on above comments, ostree info avialable in 3 places:

1. repository info - shows ostree branch count

2. cv info - shows ostree repo name/label/id etc

3. ostree-branch info and list commands


Ostree info under selected CV, along with info of other contents.


 ~]# hammer -u admin -p changeme content-view info --id 3 --organization-id 1
ID:                     3
Name:                   custom_ostree
Label:                  custom_ostree
Composite:              false
Description:            
Content Host Count:     0
Organization:           Default Organization
Yum Repositories:       
 1) ID:    2
    Name:  sat6tool7
    Label: sat6tool7
Docker Repositories:    
 1) ID:    24
    Name:  busybox
    Label: busybox
OSTree Repositories:    
 1) ID:    7
    Name:  rhel7_ostree
    Label: rhel7_ostree
 2) ID:    8
    Name:  f23_ostree
    Label: f23_ostree
Puppet Modules:         
 1) ID:      1
    Name:    motd
    Author:  jeffmccune
    Created: 2016/03/31 09:45:33
    Updated: 2016/03/31 09:45:33
Lifecycle Environments: 
 1) ID:   2
    Name: Dev
 2) ID:   1
    Name: Library
Versions:               
 1) ID:        3
    Version:   1.0
    Published: 2016/03/31 09:35:36
 2) ID:        4
    Version:   2.0
    Published: 2016/03/31 09:41:37
 3) ID:        5
    Version:   3.0
    Published: 2016/03/31 09:45:43
Components:             

Activation Keys:
Comment 13 errata-xmlrpc 2016-07-27 05:27:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.