Bug 1317124 - preupg --mode migrate fails with (stripped) AttributeError due to Application.path
preupg --mode migrate fails with (stripped) AttributeError due to Application...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Petr Hracek
Tereza Cerna
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-12 01:57 EST by Alois Mahdal
Modified: 2016-08-05 15:33 EDT (History)
6 users (show)

See Also:
Fixed In Version: preupgrade-assistant-2.1.6-4.el6
Doc Type: Bug Fix
Doc Text:
Cause: Execute preupgrade-assistant with --mode option Consequence: preupgrade-assistant exits with traceback like Application does not have not attribute 'path'. Preupgrade-assistant uses wrong directory name. Fix: Using proper directory in Python code fixes this problem Result: No traceback is shown in case of --mode option
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-11 04:27:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alois Mahdal 2016-03-12 01:57:33 EST
Description of problem
======================

preupg fails with --migrate option

    # preupg --mode migrate --force
    Gathering logs used by preupgrade assistant:
    All installed packages                                 : 01/10 ...finished (time 00:01s)
    All changed files                                      : 02/10 ...finished (time 00:50s)
    Changed config files                                   : 03/10 ...finished (time 00:00s)
    All users                                              : 04/10 ...finished (time 00:00s)
    All groups                                             : 05/10 ...finished (time 00:00s)
    Service statuses                                       : 06/10 ...finished (time 00:00s)
    All installed files                                    : 07/10 ...finished (time 00:01s)
    All local files                                        : 08/10 ...finished (time 00:00s)
    All executable files                                   : 09/10 ...finished (time 00:00s)
    RedHat signed packages                                 : 10/10 ...finished (time 00:00s)
    Usage: preupg [options]

    preupg: error: 'Application' object has no attribute 'path'
    #


Version-Release number of selected component
============================================

preupgrade-assistant-2.1.5-3.el6.noarch


How reproducible
================

Always


Steps to Reproduce
==================

run preupg as above


Actual results
==============

As above; preupg dies with "Usage message" that's apparently just
"rebranded" code integrity exception (looks like AttributeError).


Expected results
================

No error or sane/helpful error
Comment 2 Petr Hracek 2016-04-27 08:50:51 EDT
This is fixed by upstream commit https://github.com/phracek/preupgrade-assistant/commit/1c31d567c5229abc9b9f8abfed7bd17b6988596d
Comment 5 errata-xmlrpc 2016-05-11 04:27:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1022.html

Note You need to log in before you can comment on or make changes to this bug.