Bug 1317147 - broken frequency scaling after suspend to RAM / resume cycle
broken frequency scaling after suspend to RAM / resume cycle
Status: CLOSED DUPLICATE of bug 1317190
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 1317146 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-12 09:24 EST by Jacek Pawlyta
Modified: 2016-03-20 09:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-20 09:17:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacek Pawlyta 2016-03-12 09:24:23 EST
Description of problem:

frequency scaling is broken after suspend/resume cycle

each suspend/resume cycle 
"current policy: frequency should be within" gest narrower

in my case after 4 cycles it goes down to
current policy: frequency should be within 800 MHz and 800 MHz

Version-Release number of selected component (if applicable):
I have tested two following kernels with the same result
kernel-4.4.4-301.fc23.x86_64
kernel-4.5.0-0.rc7.git0.2.fc24.x86_64

How reproducible:
always

Steps to Reproduce:
1. cold boot laptop
2. login into KDE
3. supend laptop

Actual results:

frequency range available in the "current policy" is limited more than hardware limits
i.e.

analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 800 MHz - 2.50 GHz
  available frequency steps: 2.50 GHz, 2.50 GHz, 2.00 GHz, 1.60 GHz, 1.20 GHz, 800 MHz
  available cpufreq governors: conservative, userspace, powersave, ondemand, performance
  current policy: frequency should be within 800 MHz and 1.20 GHz.
                  The governor "conservative" may decide which speed to use
                  within this range.
  current CPU frequency is 1.20 GHz (asserted by call to hardware).
  boost state support:
    Supported: yes
    Active: yes
analyzing CPU 1:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 1
  CPUs which need to have their frequency coordinated by software: 1
  maximum transition latency: 10.0 us.
  hardware limits: 800 MHz - 2.50 GHz
  available frequency steps: 2.50 GHz, 2.50 GHz, 2.00 GHz, 1.60 GHz, 1.20 GHz, 800 MHz
  available cpufreq governors: conservative, userspace, powersave, ondemand, performance
  current policy: frequency should be within 800 MHz and 1.20 GHz.
                  The governor "conservative" may decide which speed to use
                  within this range.
  current CPU frequency is 1.20 GHz (asserted by call to hardware).
  boost state support:
    Supported: yes
    Active: yes


Expected results:
frequency range available for "current policy" stays the same after each resume

Additional info:

the only way to have full hardware range available is to reboot the machine

kernel-4.3.5-300.fc23.x86_64 in the same configuration works OK

Lenovo G550 laptop with 
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 23
Model name:            Intel(R) Core(TM)2 Duo CPU     T9300  @ 2.50GHz
Stepping:              6
CPU MHz:               800.000
CPU max MHz:           2501.0000
CPU min MHz:           800.0000
BogoMIPS:              4987.79
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              6144K
NUMA node0 CPU(s):     0,1
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 lahf_lm ida dtherm tpr_shadow vnmi flexpriority
Comment 1 Jacek Pawlyta 2016-03-12 12:17:15 EST
*** Bug 1317146 has been marked as a duplicate of this bug. ***
Comment 2 Jacek Pawlyta 2016-03-20 09:17:47 EDT

*** This bug has been marked as a duplicate of bug 1317190 ***

Note You need to log in before you can comment on or make changes to this bug.