Bug 131718 - LVM at install does not work
Summary: LVM at install does not work
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: s390x Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-03 15:50 UTC by Samuel Kielek
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-10 17:27:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception error #1 (1019 bytes, text/plain)
2004-09-07 20:42 UTC, Samuel Kielek
no flags Details
exception error #2 (960 bytes, text/plain)
2004-09-07 20:43 UTC, Samuel Kielek
no flags Details

Description Samuel Kielek 2004-09-03 15:50:51 UTC
Description of problem:
Installing RHEL3 U2 using NFS with GUI and using LVM does not work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Choose NFS install method
2. Create /boot as ext3 partition on dasda
3. Create LVM PV using remaining space
4. Define VG for / (ext3)
5. Configure remaining install options to your preference
6. When the installer gets to the point where it sets up the
partitions and begins formating, anaconda will have an exception error .
   
Actual results:
The LVM configuration is being created on the initial installer image,
instead of on the new system image.

For example, if you defined a PV on /dev/dasda called 'rootvg' in disk
druid, it creates the following:

/dev/rootvg/group 

Expected results:

It should have created:

/mnt/sysimage/dev/rootvg/group

Additional info:

None

Comment 1 Samuel Kielek 2004-09-04 17:35:57 UTC
I just re-read my original comments are realized how confusing they
are. It was a long Friday and I was doing too many things at the same
time I guess... My configuration was with 2 dasd devices (a and b). I
used these two devices to create a physical volume. There was only one
volume group, 'rootvg'. I first tried to create a number of logical
volumes such as 'lvroot' for /, 'lvhome' for /home, 'lvopt' for /opt,
etc. It would get to the point where it would create the PV and the
VG, but would fail on creating the LV's. Anaconda would error with
unable locate /dev/rootvg/lvroot.

I was able to get the install to complete by manually configuring lvm
from the installation image shell and only configuring a single LV,
'lvroot'. After I did this, I could re-start the installation and only
had to define the mount points in disk druid as it had the vlm
configuation I defined manually. After this, no exception errors. It
formatted lvroot and installed all the packages.

Comment 2 Jeremy Katz 2004-09-07 04:13:31 UTC
This works for me here.  Can you please provide the exception you receive?

Comment 3 Samuel Kielek 2004-09-07 20:42:38 UTC
Created attachment 103558 [details]
exception error #1

Comment 4 Samuel Kielek 2004-09-07 20:43:33 UTC
Created attachment 103559 [details]
exception error #2

Comment 5 Jeremy Katz 2004-09-07 20:54:46 UTC
This should be fixed in update 3.

Comment 6 Samuel Kielek 2004-09-10 17:27:25 UTC
Installed U3 and there was no problem at all..


Note You need to log in before you can comment on or make changes to this bug.