Bug 1317187 - Ship AppStream metadata file
Ship AppStream metadata file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gimp-lqr-plugin (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sven Lankes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-12 17:17 EST by Jiri Eischmann
Modified: 2016-03-20 15:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-20 15:08:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
appstream metadata file (594 bytes, application/xml)
2016-03-12 17:17 EST, Jiri Eischmann
no flags Details

  None (edit)
Description Jiri Eischmann 2016-03-12 17:17:18 EST
Created attachment 1135687 [details]
appstream metadata file

The package doesn't ship AppStream [1] metadata file, so it doesn't appear in GIMP profile in the default app catalog GNOME Software and is not easily discoverable and installable for users.

I've already filed a bug upstream [2] because it should be ideally included there since it's used across Linux distributions, but unless/until upstream ships it it should be included downstream as the packaging guidelines say [3].

I've created the file for you, see the attachment.

[1] http://www.freedesktop.org/software/appstream/docs/sect-Quickstart-Addons.html
[2] https://github.com/carlobaldassi/gimp-lqr-plugin/issues/1
[3] https://fedoraproject.org/wiki/Packaging:AppData

Note You need to log in before you can comment on or make changes to this bug.