Bug 131719 - bad error message or incorrect polling of speed and duplex with bonded interface and tg3 driver
bad error message or incorrect polling of speed and duplex with bonded interf...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-03 11:52 EDT by Eric Paris
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:56:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2004-09-03 11:52:12 EDT
Description of problem:
When activating a bonded interface (in my case mode=1) with broadcom
chipset nic cards (tg3 driver) the error message:
bond_enslave(): failed to get speed/deuplex from eth1, speed forced to
100Mbps, duplex forces to Full.
Is returned.  The failure is on line 821 of bond_main.c where IOCTL
returns -95 (EOPNOSUPP)   Since we are able to see the speed duplex
using ethtool we either need to change how we poll the card or change
the error message.   We do not actually set the speed/duplex of the
card to 100 full, we leave it alone.  If the card is a gig card that
autoneg. to 1000/full we return that message, but the card actually
runs at 1000/full.  

This has been seen with gig fiber cards (which obviously can only run
at gig speed) and even the BCM5700 and BCM5702X copper cards which are
capable of 100/full but continue to run at 1000/full.

Version-Release number of selected component (if applicable):
2.4.12-15.0.4

How reproducible:
Always

Steps to Reproduce:
1. Configure bonding with a BCM5700 (or other chipset) and tg3 driver
2. ifup the bond interface/insmod the bonding module
3. enjoy the error message
    

Expected Results:  Either a correct poll of the speed/duplex or a
message saying it wasn't polled, but not saying that speed/duplex was
changed to something it wasn't
Comment 4 Ernie Petrides 2004-09-09 21:01:06 EDT
A fix for this problem has just been committed to the RHEL3 U4
patch pool this evening (in kernel version 2.4.21-20.4.EL).
Comment 5 John Flanagan 2004-12-20 15:56:11 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.