Bug 131721 - ata_sis is causing problems
ata_sis is causing problems
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-03 12:01 EDT by Frederic Soulier
Modified: 2013-07-02 22:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 21:02:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Knoppix 3.6 (kernel 2.6 .config file) (42.38 KB, text/plain)
2004-09-06 03:58 EDT, Frederic Soulier
no flags Details

  None (edit)
Description Frederic Soulier 2004-09-03 12:01:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040614 Firefox/0.8

Description of problem:
Hardware
========
   Asus P4S800D-E Deluxe (USB1.0/2.0, firewire, Gigabit Eth, Sata)
      (SiS964 / SiS180)
   2Gb Ram
   Lite-On DVD-RW DL 832S
   Chaintech GeForce 5900XT 128Mb
   USB Card Reader 7 in 1
   1 SATA 160Gb HD 
   1 PATA 27Gb HD

I want to try to install FC3 Test1 on the SATA HD which has 2 primary
partitions:
   - a small 8Mb FAT16 for XOSL (boot loader)
   - a 50Gb NTFS partition

The PATA drive contains an installation on Linux Mandrake 9.2 with
Ext2, Ext3 and XFS partitions.

Installing from CDRom FC3 Test1.
Same thing happened when installing normally (enter), with 'linux
noacpi' and with 'linux acpi=off'

When loading driver for SiS SATA (sata_sis) I get a small black
rectangle (~ 5cm x 0.5cm) next to "Loading sata_sis driver..." with
garbage characters in it.

Alt-F2 shows:
  * inserted /tmp/libata.ko

Alt-F4 shows:
  <3> irq 10: Please try booting with acpi=off and report a bug
  ...
  <0> Disabling IRQ #10



Note:
I've tried several other distro and so far:-
   - Linux Mandrake 10.1 beta2           Same pbm with irq #10
   - Yoper Linux                         Same pbm with irq #10
   - Arch Linux                          Same pbm with irq #10

   - Gentoo 2004.2                       Ok. I can fdisk/cfdisk the
                                         SATA HD
   - Knoppix 3.6 (kernel 2.6)            Ok. I get 2 HD icons in KDE
                                         once booted and I can browse
                                         both partitions on SATA HD.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot CD
2. Press enter
3. wait a few seconds until it loads the sata_sis driver
    

Actual Results:  Installation frozen although I can Alt-F1, Alt-F2, etc...

Expected Results:  I expect it loads the driver and recognizes the
SATA drive properly and carry on with the rest of the installation.

Additional info:
Comment 1 Frederic Soulier 2004-09-05 08:38:04 EDT
Some info from Knoppix 3.6 (maybe it helps):

root@ttyp0[~]# lsmod
Module                  Size  Used by
nls_cp437               9600  0
nls_iso8859_1           7936  0
ntfs                  111468  0
snd_mixer_oss          18688  0
snd                    47588  1 snd_mixer_oss
via_agp                10624  0
sworks_agp             10784  0
sis_agp                 9732  1
nvidia_agp              9628  0
intel_mch_agp          11664  0
intel_agp              19612  0
efficeon_agp           10016  0
ati_agp                10252  0
amd_k7_agp              9612  0
amd64_agp              12360  0
ali_agp                 9088  0
agpgart                29868  11
via_agp,sworks_agp,sis_agp,nvidia_agp,intel_mch_agp,intel_agp,efficeon_agp,ati_agp,amd
_k7_agp,amd64_agp,ali_agp
autofs                 18048  1
af_packet              21000  0
i810_audio             33684  1
ac97_codec             19212  1 i810_audio
soundcore              11232  3 snd,i810_audio
sk98lin               152744  0
dmfe                   21660  0
crc32                   8064  1 dmfe
parport_pc             37568  0
parport                36936  1 parport_pc
8250                   34480  0
serial_core            22528  1 8250
usb_storage            61120  0
ohci_hcd               22276  0
uhci_hcd               31760  0
ds                     17284  0
yenta_socket           20480  0
pcmcia_core            56772  2 ds,yenta_socket
thermal                14352  0
processor              19776  1 thermal
fan                     7052  0
button                  8984  0
battery                11916  0
ac                      7564  0
rtc                    14920  0
cloop                  14976  1
sbp2                   24712  0
ohci1394               33796  0
ieee1394              302008  2 sbp2,ohci1394
usbcore                95840  5 usb_storage,ohci_hcd,uhci_hcd
ide_scsi               17156  1

There is no 'sata_sis' module so they must have that stuff compiled in the
kernel or something?

root@ttyp0[~]# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: HDS722516VLSA80  Rev: V34O
  Type:   Direct-Access                    ANSI SCSI revision: 05
Host: scsi2 Channel: 00 Id: 00 Lun: 00
  Vendor: LITE-ON  Model: DVDRW SOHW-832S  Rev: VS01
  Type:   CD-ROM                           ANSI SCSI revision: 02
Host: scsi3 Channel: 00 Id: 00 Lun: 00
  Vendor: Generic  Model: STORAGE DEVICE   Rev: 0128
  Type:   Direct-Access                    ANSI SCSI revision: 02

My SATA drive is on scsi0.

  root@ttyp0[~]# cat /proc/interrupts
           CPU0
  0:     566204          XT-PIC  timer
  1:        332          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  5:        230          XT-PIC  ohci_hcd, ohci_hcd, SysKonnect SK-98xx, SiS 7012
  6:         40          XT-PIC  floppy
  8:          1          XT-PIC  rtc
  9:          0          XT-PIC  acpi
 10:         98          XT-PIC  libata, ohci1394
 11:        296          XT-PIC  ohci_hcd, eth0
 12:      28962          XT-PIC  i8042
 14:         32          XT-PIC  ide0
 15:       1702          XT-PIC  ide1
NMI:          0
LOC:     566049
ERR:          0
MIS:          0

Hope it give some valuable info.
I don't see why it works for Knoppix 3.6 (kernel 2.6.7 SMP) and it cannot work
for FC3...
Comment 2 Frederic Soulier 2004-09-06 03:58:15 EDT
Created attachment 103504 [details]
Knoppix 3.6 (kernel 2.6 .config file)

Booting Knoppix 3.6 with 'knoppix26 lang=uk screen=1600x1200 depth=32' I get a
perfectly working SATA drive with my 2 partitions (FAT16 and NTFS) accessible.
Comment 3 Frederic Soulier 2004-09-06 03:59:42 EDT
From Knoppix 3.6 (kernel 2.6 .config file) for SATA:

CONFIG_SCSI_SATA=y
CONFIG_SCSI_SATA_SVW=y
CONFIG_SCSI_SATA_PROMISE=y
CONFIG_SCSI_SATA_SX4=y
CONFIG_SCSI_SATA_SIL=y
CONFIG_SCSI_SATA_SIS=y
CONFIG_SCSI_SATA_VIA=y
CONFIG_SCSI_SATA_VITESSE=y

I've attached the full Kernel 2.6 .config file in case it's relevant.
So I don't know if the reason it works in Knoppix 3.6 is the sata_sis
driver
compiled in the kernel but something in Knoppix kernel config makes it
work prefectly which is not the case for FC3 Test1.
Comment 4 Frederic Soulier 2004-09-09 05:38:56 EDT
[copying info from bug reports from other distro]
Knoppix has up local apic disabled, which is probably what is allowing
it to see the SATA controller.

It seems there is a bug in 2.6.8 kernel that prevents disabling local
apic on boot with nolapic boot parameter.
http://lkml.org/lkml/2004/6/26/63

We should not have APIC enabled in the BOOT kernel, since APIC just
gives a performance improvement (which is less critical than
ensuring every machine gets through installation). But, it must also
be possible to disable APIC after installation ...
Comment 5 Arjan van de Ven 2004-09-09 05:40:11 EDT
this makes absolutely no sense since we do not have apic enabled.
Comment 6 Frederic Soulier 2004-09-09 05:59:58 EDT
Ok. You don't have apic enabled and my last comments made no sense.
Fine. What about the fact that the installer fails on this board with
these chipsets (SiS180/SiS964) with a SATA drive and that several
distro seems to have the same problem (which seems to point to a
kernel pbm)?
Instead of just saying it makes no sense maybe some pointers to what
it could be and what I could try to help FC would be more useful...
Comment 7 Frederic Soulier 2004-09-21 16:34:16 EDT
Just tried FC3 Test2 and the exact same pbm happened...
Comment 8 Frederic Soulier 2004-09-24 05:04:08 EDT
Well following bug report is about the same pbm I believe:
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=132990
Comment 9 James Todd 2004-10-08 20:23:29 EDT
I have the identical board (Asus P4S800D-E Deluxe, SiS964 / SiS180)
and the identical problem to the poster. acpi=off also has no effect
for me.  This has happened with Core 3 Test 1 and Test 2.
Comment 10 Dave Jones 2005-07-15 14:43:56 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 11 Dave Jones 2005-10-02 21:02:06 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.