Bug 1317213 - On Boot, graphical interface doesn't start properly, causing systemd-ask-password-plymouth to not work
On Boot, graphical interface doesn't start properly, causing systemd-ask-pass...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-12 19:52 EST by Mike Kwong
Modified: 2016-03-19 17:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-19 17:31:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot messages with kernel 4.4.4 (3.28 MB, application/x-tar)
2016-03-15 17:58 EDT, Giovanni Tirloni
no flags Details

  None (edit)
Description Mike Kwong 2016-03-12 19:52:36 EST
Description of problem:
On boot to kernel-4.4.4-301.fc23.x86_64, graphical interface doesn't start. Instead we drop to the terminal interface, eventually the boot gets stuck on systemd-ask-password-plymouth and the boot does not proceed.

Dropping down to kernel-4.4.3-300.fc23.x86_64 works as normal.

Version-Release number of selected component (if applicable):
kernel-4.4.4-301.fc23.x86_64

How reproducible:
Always fails the same way

Steps to Reproduce:
1. Boot up the machine and select kernel-4.4.4-301.fc23.x86_64
2.
3.

Actual results:
The machine boots up, drops to terminal with the boot messages. Eventually a message shows up referring to systemd-ask-password-plymouth and the boot does not proceed.

Expected results:
The machine boots up, Plymouth starts, and the dialog box for inputing the decryption password shows up.

Additional info:
The machine has an LUKS encrypted boot disk. The graphics card is an AMD Tonga 285.
Comment 1 Giovanni Tirloni 2016-03-15 17:50:06 EDT
Same issue on a DELL Inspiron laptop with AMD R7 M265 GPU and SSD disk without LUKS. Same workaround works (boot 4.4.3).
Comment 2 Giovanni Tirloni 2016-03-15 17:58 EDT
Created attachment 1136782 [details]
Boot messages with kernel 4.4.4
Comment 3 Giovanni Tirloni 2016-03-16 07:23:56 EDT
Kernel 4.5.0 also works (updated to F24 Alpha)
Comment 4 Mike Kwong 2016-03-19 17:31:14 EDT
Kernel 4.4.5 also works. Closing this since this now works in F23.

Note You need to log in before you can comment on or make changes to this bug.