Bug 1317241 - No configuration file found
Summary: No configuration file found
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 23
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-13 09:49 UTC by Todd
Modified: 2016-03-25 20:37 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-18 22:15:21 UTC


Attachments (Terms of Use)

Description Todd 2016-03-13 09:49:23 UTC
livecd-tools-20.1-3.el7.nux.x86_64

I can't get this to boot:

# livecd-iso-to-disk --format --reset-mbr --delete-home --home-size-mb 4095 --overlay-size-mb 4095 --unencrypted-home Fedora-Live-Xfce-x86_64-23-10.iso /dev/sdc

Error when booting:

      ERROR: No configuration file found
      No DEFAULT or UI Configuration directive found

Comment 1 Todd 2016-03-13 09:50:54 UTC
dd works fine with this iso, but I lose all my fancy stuff

Comment 2 Brian Lane 2016-03-16 22:54:28 UTC
Stop using old versions of livecd-tools with new releases.

Comment 3 Todd 2016-03-18 20:38:10 UTC
Which version do you want me to use with Scientific Linux 7.2?   I also have
Fedora Core 23 somewhat available

Comment 4 Brian Lane 2016-03-18 22:15:21 UTC
Use a recent fedora version.

Comment 5 Todd 2016-03-25 20:37:51 UTC
Hi Brian,

Thank you for helping looking into this for me.  Very much appreciated.

You are correct.  It was a revision issue.  Verifying not a bug.  

The following updated livecd-tools (Nux was extremely helpful):

yum install http://li.nux.ro/download/nux/tmp/livecd-tools7/livecd-tools-23.2-3.el7.nux.x86_64.rpm http://li.nux.ro/download/nux/tmp/livecd-tools7/python-imgcreate-23.2-3.el7.nux.x86_64.rpm http://li.nux.ro/download/nux/tmp/livecd-tools7/python-kickstart-2.13-1.el7.nux.noarch.rpm http://li.nux.ro/download/nux/tmp/syslinux7/syslinux-6.03-1.el7.nux.x86_64.rpm http://li.nux.ro/download/nux/tmp/syslinux7/syslinux-nonlinux-6.03-1.el7.noarch.rpm http://li.nux.ro/download/nux/tmp/livecd-tools7/pykickstart-2.13-1.el7.nux.noarch.rpm http://li.nux.ro/download/nux/tmp/livecd-tools7/python3-kickstart-2.13-1.el7.nux.noarch.rpm http://li.nux.ro/download/nux/tmp/livecd-tools7/python3-requests-1.2.3-5.fc20.noarch.rpm http://li.nux.ro/download/nux/tmp/livecd-tools7/python3-six-1.4.1-1.fc20.noarch.rpm http://li.nux.ro/download/nux/tmp/livecd-tools7/python3-urllib3-1.8.2-1.fc20.noarch.rpm http://li.nux.ro/download/nux/tmp/livecd-tools7/python3-chardet-2.0.1-10.fc20.noarch.rpm http://li.nux.ro/download/nux/tmp/syslinux7/syslinux-extlinux-6.03-1.el7.nux.x86_64.rpm http://li.nux.ro/download/nux/tmp/syslinux7/syslinux-extlinux-nonlinux-6.03-1.el7.noarch.rpm http://li.nux.ro/download/nux/dextop/el7Workstation/x86_64/python3-3.3.2-12.el7.nux.x86_64.rpm http://li.nux.ro/download/nux/dextop/el7Workstation/x86_64/python3-libs-3.3.2-12.el7.nux.x86_64.rpm


And the following work perfectly:

#  livecd-iso-to-disk --format --reset-mbr --delete-home --home-size-mb 4095 --overlay-size-mb 4095 --unencrypted-home /home/kvm/Fedora-Live-Xfce-x86_64-23-10.iso /dev/sdc
...
Installing boot loader
/media/tgttmp.8zkogK/syslinux is device /dev/sdc1
Target device is now set up with a Live image!


-T


Note You need to log in before you can comment on or make changes to this bug.