Bug 1317248 - Add host name as header to JsonRpcUtils
Add host name as header to JsonRpcUtils
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.3.2
x86_64 Linux
low Severity high (vote)
: ovirt-3.6.5
: 3.6.5.1
Assigned To: Eldad Marciano
Eldad Marciano
: CodeChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 06:16 EDT by Eldad Marciano
Modified: 2016-04-21 10:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:40:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
mperina: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 39888 master MERGED construct jsonrpc with identifier name. 2016-03-30 11:33 EDT
oVirt gerrit 55501 ovirt-engine-3.6.5 MERGED construct jsonrpc with identifier name. 2016-04-01 03:10 EDT
oVirt gerrit 55502 ovirt-engine-3.6 MERGED construct jsonrpc with identifier name. 2016-03-31 08:32 EDT
oVirt gerrit 55521 master MERGED core: Fix formatting in JsonRpcUtils 2016-03-31 15:49 EDT

  None (edit)
Description Eldad Marciano 2016-03-13 06:16:15 EDT
Description of problem:
when working with ovirt-vdsmfake with many hosts we have to use header name in order to identify the hostname for establishing correct channels.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Kaul 2016-03-13 17:17:26 EDT
Is that a bug? A feature request?
Comment 2 Martin Perina 2016-03-16 09:02:01 EDT
It's a feature request, but it's important only for fake-vdsm as normal vdsm will completely ignore this new information sent from engine. Since vdsm ignores it completely, QA don't need to test this patch.

Patcch is already posted and waiting to be merged.

Scale team needs it for 3.6 scale testing, so that's why it's targeted to 3.6
Comment 3 Mike McCune 2016-03-28 19:13:32 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Note You need to log in before you can comment on or make changes to this bug.