Bug 1317267 - dnf do not install old kernel, but yum do it
dnf do not install old kernel, but yum do it
Status: CLOSED DUPLICATE of bug 1191611
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 11:27 EDT by Marco Motta
Modified: 2016-03-14 09:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 09:28:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Motta 2016-03-13 11:27:54 EDT
Description of problem:

dnf do not install an old kernel for "conflicting requests", but yum-deprecated do it.

Version-Release number of selected component (if applicable):

# dnf --version
1.1.6
  Installato: dnf-0:1.1.6-2.fc23.noarch da 2016-02-05 20:03
  Build    : Fedora Project su 2016-02-03 12:23

  Installato: rpm-0:4.13.0-0.rc1.12.fc23.x86_64 da 2016-03-04 05:54
  Build    : Fedora Project su 2016-02-29 09:53


How reproducible:

Download rpms of old kernel and try to install them. Dnf fails for "conflicting requests", but yum-deprecated install them without problems.

Steps to Reproduce:

# mkdir -p ~/test_dnf
# cd ~/test_dnf
# wget https://kojipkgs.fedoraproject.org/packages/kernel/4.2.8/300.fc23/x86_64/kernel-4.2.8-300.fc23.x86_64.rpm https://kojipkgs.fedoraproject.org/packages/kernel/4.2.8/300.fc23/x86_64/kernel-core-4.2.8-300.fc23.x86_64.rpm https://kojipkgs.fedoraproject.org/packages/kernel/4.2.8/300.fc23/x86_64/kernel-modules-4.2.8-300.fc23.x86_64.rpm
# ls
kernel-4.2.8-300.fc23.x86_64.rpm       kernel-modules-4.2.8-300.fc23.x86_64.rpm
kernel-core-4.2.8-300.fc23.x86_64.rpm
# dnf install *.rpm
Last metadata expiration check performed 0:49:17 ago on Sun Mar 13 15:32:33 2016.
Errore: conflicting requests.
conflicting requests.
conflicting requests
(try to add '--allowerasing' to command line to replace conflicting packages)
# dnf install *.rpm --allowerasing
Last metadata expiration check performed 0:49:49 ago on Sun Mar 13 15:32:33 2016.
Errore: conflicting requests.
conflicting requests.
conflicting requests

# yum-deprecated install *.rpm
ùYum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.

Plugin abilitati:langpacks, remove-with-leaves
Analisi di kernel-4.2.8-300.fc23.x86_64.rpm: kernel-4.2.8-300.fc23.x86_64
kernel-4.2.8-300.fc23.x86_64.rpm contrassegnato per l'installazione
kernel-4.2.8-300.fc23.x86_64.rpm contrassegnato per l'installazione
kernel-4.2.8-300.fc23.x86_64.rpm contrassegnato per l'installazione
Analisi di kernel-core-4.2.8-300.fc23.x86_64.rpm: kernel-core-4.2.8-300.fc23.x86_64
kernel-core-4.2.8-300.fc23.x86_64.rpm contrassegnato per l'installazione
kernel-core-4.2.8-300.fc23.x86_64.rpm contrassegnato per l'installazione
kernel-core-4.2.8-300.fc23.x86_64.rpm contrassegnato per l'installazione
Analisi di kernel-modules-4.2.8-300.fc23.x86_64.rpm: kernel-modules-4.2.8-300.fc23.x86_64
kernel-modules-4.2.8-300.fc23.x86_64.rpm contrassegnato per l'installazione
kernel-modules-4.2.8-300.fc23.x86_64.rpm contrassegnato per l'installazione
kernel-modules-4.2.8-300.fc23.x86_64.rpm contrassegnato per l'installazione
Risoluzione dipendenze
--> Esecuzione del controllo di transazione
---> Pacchetto kernel.x86_64 0:4.2.8-300.fc23 settato per essere installato
---> Pacchetto kernel-core.x86_64 0:4.2.8-300.fc23 settato per essere installato
---> Pacchetto kernel-modules.x86_64 0:4.2.8-300.fc23 settato per essere installato
--> Risoluzione delle dipendenze completata
--> Esecuzione del controllo di transazione
---> Pacchetto kernel.x86_64 0:4.4.2-301.fc23 settato per essere eliminato
---> Pacchetto kernel-core.x86_64 0:4.4.2-301.fc23 settato per essere eliminato
--> Elaborazione dipendenza: kernel-uname-r = 4.4.2-301.fc23.x86_64 per il pacchetto: kmod-VirtualBox-4.4.2-301.fc23.x86_64-5.0.14-1.fc23.x86_64
--> Elaborazione dipendenza: kernel-uname-r = 4.4.2-301.fc23.x86_64 per il pacchetto: kernel-modules-extra-4.4.2-301.fc23.x86_64
---> Pacchetto kernel-modules.x86_64 0:4.4.2-301.fc23 settato per essere eliminato
--> Esecuzione del controllo di transazione
---> Pacchetto kernel-modules-extra.x86_64 0:4.4.2-301.fc23 settato per essere eliminato
---> Pacchetto kmod-VirtualBox-4.4.2-301.fc23.x86_64.x86_64 0:5.0.14-1.fc23 settato per essere eliminato
--> Risoluzione delle dipendenze completata

Dipendenze risolte

================================================================================
 Package        Arch   Versione        Repository                          Dim.
================================================================================
Installazione:
 kernel         x86_64 4.2.8-300.fc23  /kernel-4.2.8-300.fc23.x86_64      0.0  
 kernel-core    x86_64 4.2.8-300.fc23  /kernel-core-4.2.8-300.fc23.x86_64  51 M
 kernel-modules x86_64 4.2.8-300.fc23  /kernel-modules-4.2.8-300.fc23.x86_64
                                                                           17 M
Rimozione in corso:
 kernel         x86_64 4.4.2-301.fc23  installed                          0.0  
 kernel-core    x86_64 4.4.2-301.fc23  installed                           52 M
 kernel-modules x86_64 4.4.2-301.fc23  installed                           18 M
Rimozioni per dipendenze:
 kernel-modules-extra
                x86_64 4.4.2-301.fc23  installed                          2.1 M
 kmod-VirtualBox-4.4.2-301.fc23.x86_64
                x86_64 5.0.14-1.fc23   installed                          1.1 M

Riepilogo della transazione
================================================================================
Install  3 Pacchetto
Remove   3 Pacchetto (+2 Pacchetti dipendenti)

Dimensione totale: 68 M
Is this ok [y/d/N]: s
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction (shutdown inhibited)
Attenzione: RPMDB modificato al di fuori di yum.
  Installazione     : kernel-core-4.2.8-300.fc23.x86_64                     1/8 
  Installazione     : kernel-modules-4.2.8-300.fc23.x86_64                  2/8 
  Installazione     : kernel-4.2.8-300.fc23.x86_64                          3/8 
  Pulizia           : kernel-4.4.2-301.fc23.x86_64                          4/8 
  Eliminazione      : kmod-VirtualBox-4.4.2-301.fc23.x86_64-5.0.14-1.fc23   5/8 
  Eliminazione      : kernel-modules-extra-4.4.2-301.fc23.x86_64            6/8 
  Pulizia           : kernel-modules-4.4.2-301.fc23.x86_64                  7/8 
  Pulizia           : kernel-core-4.4.2-301.fc23.x86_64                     8/8 
avvertimento: file /lib/modules/4.4.2-301.fc23.x86_64/updates: rimozione fallita: File o directory non esistente
  Verifica in corso : kernel-4.2.8-300.fc23.x86_64                          1/8 
  Verifica in corso : kernel-modules-4.2.8-300.fc23.x86_64                  2/8 
  Verifica in corso : kernel-core-4.2.8-300.fc23.x86_64                     3/8 
  Verifica in corso : kmod-VirtualBox-4.4.2-301.fc23.x86_64-5.0.14-1.fc23   4/8 
  Verifica in corso : kernel-core-4.4.2-301.fc23.x86_64                     5/8 
  Verifica in corso : kernel-modules-extra-4.4.2-301.fc23.x86_64            6/8 
  Verifica in corso : kernel-4.4.2-301.fc23.x86_64                          7/8 
  Verifica in corso : kernel-modules-4.4.2-301.fc23.x86_64                  8/8 

Eliminato:
  kernel.x86_64 0:4.4.2-301.fc23           kernel-core.x86_64 0:4.4.2-301.fc23  
  kernel-modules.x86_64 0:4.4.2-301.fc23  

Dipendenza rimossa:
  kernel-modules-extra.x86_64 0:4.4.2-301.fc23                                  
  kmod-VirtualBox-4.4.2-301.fc23.x86_64.x86_64 0:5.0.14-1.fc23                  

Installato:
  kernel.x86_64 0:4.2.8-300.fc23           kernel-core.x86_64 0:4.2.8-300.fc23  
  kernel-modules.x86_64 0:4.2.8-300.fc23  

Completo!



Actual results:


Expected results:


Additional info:
Comment 1 Jaroslav Mracek 2016-03-14 09:28:46 EDT

*** This bug has been marked as a duplicate of bug 1191611 ***

Note You need to log in before you can comment on or make changes to this bug.