Bug 1317287 - Possible USB 3.0 power supply issues that bricks recent ASUS motherboards
Possible USB 3.0 power supply issues that bricks recent ASUS motherboards
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 15:19 EDT by Matt
Modified: 2016-11-09 07:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-26 12:44:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt 2016-03-13 15:19:38 EDT
Description of problem:

USB 3.0 hard drive enclosures and docking stations sometimes aren't recognized and/or powered correctly by Fedora on recent ASUS hardware, with recent Intel CPU's.

I own an ASUS laptop and ASUS motherboard based desktop. If either machine is booted into BIOS it can see all my USB 3.0 perperials everytime. If i boot Windows 7 it can see all my USB 3.0 perperials everytime (tested on laptop only).

If I boot into Fedora on either machine, the majority of times only one of the two USB 3.0 ports on each system will see USB 3.0 perperials.

**Please note my specific hardware is listed at the end of this bug report** 

When I originally purchased my laptop I ran Debian on it. After a few weeks of owning it I awoke it from a suspend and plugged in a USB 3.0 hard drive enclosure (perhaps while it was still waking), the laptop died (holding down the power button didn't bring it back).

When I originally purchased the motherboard, I RMA'd it because one USB 3.0 port didn't seem to work at all in Fedora (at this point I hadn't tried it in the BIOS).

Now on my second motherboard, after a month of normal operation (except the issue of not seeing USB 3.0 perperials) I plugged in a USB 3.0 hard drive enclosure and the machine died (holding down power button, unplugging it, disassembling it, removing CMOS battery all didnt bring it back).

I haven't experince any USB 2.0 issues (even on USB 3.0 ports).

The only things in common between my machines are Fedora, ASUS, Intel and me. I have different USB 3.0 devices which all work and still work on other machines without issue, though it was suggested to me that one could be demanding more power than it should be?

I don't think it's an Intel CPU issues as it would be widely reported? If an ASUS issue at the very least this bug report can alert people to the potential major issue! 

Is anyone else out there with a similar issue?

Version-Release number of selected component (if applicable):

Possibly all kernels upto 4.4.4-301.fc23.x86_64 (assuming the kernel deals with USB 3.0 power/suspend)?

How reproducible:

I have so far RMA'd one ASUS laptop and now a second ASUS motherboard (all products as noted below). I originally assumed it was just faulty hardware, but it now seems like it could be a software issue.

Steps to Reproduce:
1. Buy/own same hardware.
2. Install Fedora 23 x86_64 (or maybe any variety of linux).
3. Use USB 3.0 caddies/docking staions/sticks.

Actual results:

Sometimes USB 3.0 peripherals are recognized, sometimes they aren't, and sometimes the different power demand might just be

Expected results:

Normal operation of USB 3.0 peripherals every time. 

Additional info:

Laptop:
Model: ASUS X555L 
CPU: Intel Core i3-5000U 2:0GHz
OS: Fedora 23 (encrypted root)
Kernel: 4.4.4-301.fc23.x86_64

Desktop:
Case: Coolermaster Elite 110 Mini-ITX
Mobo: Asus H110I-PLUS D3 S1151
Cpu: Intel Core i3-6300T S1151
Ram: Corsair Vengeance 8GB Low Voltage DDR3
Psu: Corsiar CS450M
OS: Fedora 23 (encrypted root)
Kernel: 4.4.4-301.fc23.x86_64

USB Devises:
USB 3.0 Coltech CE-6013 SATA 3.5" Docking Station (Single bay, plugs into mains). Tested with a variety of SATA hdds docked.
USB 3.0 Brandless 2.5" external caddy (powered via usb cable). Tested with three different caddies with a variety SATA hdds in caddies.
Comment 1 Matt 2016-03-13 15:27:11 EDT
**can't edit description above***

Actual results:

Sometimes USB 3.0 peripherals are recognized, sometimes they aren't, and sometimes they seem kill the hardware.
Comment 2 Laura Abbott 2016-09-23 15:25:28 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 3 Laura Abbott 2016-10-26 12:44:21 EDT
*********** MASS BUG UPDATE **************
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in 4 weeks. If you are still experiencing this issue, please reopen and attach the relevant data from the latest kernel you are running and any data that might have been requested previously.
Comment 4 Matt 2016-11-08 15:06:03 EST
Sorry for late reponse, can confirm am not experiencing the issue on same hardware with up to date F24

Note You need to log in before you can comment on or make changes to this bug.