Bug 1317295 - SELinux is preventing gpg2 from 'add_name' accesses on the directory .gnupg.
SELinux is preventing gpg2 from 'add_name' accesses on the directory .gnupg.
Status: CLOSED DUPLICATE of bug 1316717
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c409f18b019ec292b508ec0b4cf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 16:15 EDT by Christian Stadelmann
Modified: 2016-03-16 06:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-16 06:20:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2016-03-13 16:15:17 EDT
Description of problem:
SELinux is preventing gpg2 from 'add_name' accesses on the directory .gnupg.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gpg2 should be allowed add_name access on the .gnupg directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gpg2 /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:fwupd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                .gnupg [ dir ]
Source                        gpg2
Source Path                   gpg2
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-178.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.5.0-0.rc7.git0.2.fc24.x86_64 #1
                              SMP Tue Mar 8 02:20:08 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-03-13 21:03:47 CET
Last Seen                     2016-03-13 21:03:47 CET
Local ID                      d05984e7-2523-40f9-a147-593ad65cacfb

Raw Audit Messages
type=AVC msg=audit(1457899427.613:406): avc:  denied  { add_name } for  pid=2893 comm="gpg2" name=".gnupg" scontext=system_u:system_r:fwupd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir permissive=1


Hash: gpg2,fwupd_t,admin_home_t,dir,add_name

Version-Release number of selected component:
selinux-policy-3.13.1-178.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
type:           libreport
Comment 1 Lukas Vrabec 2016-03-16 06:20:56 EDT

*** This bug has been marked as a duplicate of bug 1316717 ***

Note You need to log in before you can comment on or make changes to this bug.