Bug 1317296 - [abrt] kernel BUG at include/linux/page-flags.h:272! [i915]
[abrt] kernel BUG at include/linux/page-flags.h:272! [i915]
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:48629eacd003057486c643994e9...
:
Depends On: 1335173
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 16:39 EDT by Giulio 'juliuxpigface'
Modified: 2016-05-25 08:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-25 08:24:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (80.29 KB, text/plain)
2016-03-13 16:39 EDT, Giulio 'juliuxpigface'
no flags Details

  None (edit)
Description Giulio 'juliuxpigface' 2016-03-13 16:39:21 EDT
Description of problem:
When powering on, I can't reach the login manager nor launch a X via "startx".

abrt collected information about this crash. I don't know if it's related.

Additional info:
reporter:       libreport-2.6.4
kernel BUG at include/linux/page-flags.h:272!
invalid opcode: 0000 [#1] SMP 
Modules linked in: fuse ccm xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_filter ebtable_nat ebtable_broute bridge stp llc ebtables ip6table_mangle ip6table_raw ip6table_security ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_filter ip6_tables iptable_mangle iptable_raw iptable_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack snd_hda_codec_hdmi snd_hda_codec_realtek arc4 snd_hda_codec_generic snd_hda_intel snd_hda_codec ath5k snd_hda_core mac80211 acer_wmi sparse_keymap snd_hwdep iTCO_wdt iTCO_vendor_support coretemp ath snd_seq cfg80211 snd_seq_device snd_pcm joydev rfkill i2c_i801 lpc_ich snd_timer
 acpi_cpufreq irda snd tpm_tis wmi soundcore tpm crc_ccitt nfsd auth_rpcgss nfs_acl lockd grace sunrpc i915 i2c_algo_bit b44 drm_kms_helper mii sdhci_pci ssb sdhci drm mmc_core serio_raw ata_generic pata_acpi yenta_socket video fjes
CPU: 0 PID: 1390 Comm: Xorg Not tainted 4.5.0-0.rc7.git2.1.fc25.i686+PAE #1
Hardware name: Acer             Extensa 5200    /Grapevine, BIOS V3.50 02/13/2007
task: f6721a00 ti: e0c60000 task.ti: e0c60000
EIP: 0060:[<f82a879a>] EFLAGS: 00010286 CPU: 0
EIP is at drm_pci_alloc+0xca/0x1e0 [drm]
EAX: 00000000 EBX: 00004000 ECX: f76898c0 EDX: 00000007
ESI: e0d7d610 EDI: c041fe80 EBP: e0c61b8c ESP: e0c61b64
 DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
CR0: 80050033 CR2: b688e000 CR3: 20c30c20 CR4: 000006f0
Stack:
 19080000 00000000 d9080000 f7239064 d9080000 024040c0 703da6d9 00000000
 f3855500 f385559c e0c61ba4 f8496fa7 00000100 f4545000 d901acc0 d901a780
 e0c61bd8 f84e1b93 00000246 00000000 00000001 00000000 f84d8f86 f454c000
Call Trace:
 [<f8496fa7>] i915_gem_object_attach_phys+0xf7/0x1a0 [i915]
 [<f84e1b93>] intel_prepare_plane_fb+0x193/0x310 [i915]
 [<f84d8f86>] ? intel_atomic_commit+0x76/0x16e0 [i915]
 [<f81b8445>] drm_atomic_helper_prepare_planes+0x45/0xb0 [drm_kms_helper]
 [<f84d9169>] intel_atomic_commit+0x259/0x16e0 [i915]
 [<f84dbab6>] ? intel_atomic_check+0x886/0x10a0 [i915]
 [<c060653d>] ? __kmalloc_track_caller+0xfd/0x330
 [<f84db230>] ? intel_link_compute_m_n+0x50/0x50 [i915]
 [<f82be46f>] ? drm_atomic_check_only+0x19f/0x670 [drm]
 [<f82bdc24>] ? drm_atomic_get_crtc_state+0x54/0xc0 [drm]
 [<c05c7c6a>] ? kmemdup+0x2a/0x40
 [<f84d8f10>] ? modeset_get_crtc_power_domains+0x140/0x140 [i915]
 [<f82be974>] drm_atomic_commit+0x34/0x60 [drm]
 [<f81b8e45>] drm_atomic_helper_update_plane+0xc5/0x110 [drm_kms_helper]
 [<f81b8d80>] ? drm_atomic_helper_wait_for_vblanks+0x220/0x220 [drm_kms_helper]
 [<f82ad963>] __setplane_internal+0x213/0x260 [drm]
 [<f82adb29>] drm_mode_cursor_common+0x179/0x390 [drm]
 [<f82b2110>] ? drm_mode_setcrtc+0x580/0x580 [drm]
 [<f82b2167>] drm_mode_cursor_ioctl+0x57/0x70 [drm]
 [<f82a2919>] drm_ioctl+0x149/0x520 [drm]
 [<c073f5bd>] ? avc_has_extended_perms+0x4d/0x660
 [<c073fbf7>] ? avc_has_perm_noaudit+0x27/0x230
 [<f82b2110>] ? drm_mode_setcrtc+0x580/0x580 [drm]
 [<c05d8cea>] ? __do_fault+0x6a/0x1a0
 [<c073fe48>] ? avc_has_perm+0x48/0xd0
 [<f82a27d0>] ? drm_getmap+0xc0/0xc0 [drm]
 [<c0633f61>] do_vfs_ioctl+0x91/0x850
 [<c07449ef>] ? selinux_file_ioctl+0x10f/0x1d0
 [<c073c0ec>] ? security_file_ioctl+0x3c/0x60
 [<c0634788>] SyS_ioctl+0x68/0x80
 [<c0403b77>] do_fast_syscall_32+0xa7/0x240
 [<c0c0fce4>] sysenter_past_esp+0x45/0x6d
Code: 00 00 40 c1 e8 0c 8d 0c 80 a1 44 26 a6 c1 8d 04 c8 8b 08 80 e5 40 0f 84 9d 00 00 00 90 8d 74 26 00 ba 28 08 2d f8 e8 06 dd 32 c8 <0f> 0b 8d 74 26 00 8d 55 ec 8d 45 e4 e8 75 75 17 c8 84 c0 0f 84
Comment 1 Giulio 'juliuxpigface' 2016-03-13 16:39:32 EDT
Created attachment 1135990 [details]
File: dmesg
Comment 2 Felix Miata 2016-04-28 17:33:39 EDT
I believe I'm reproducing this on two different i915G machines, both F24 and F25, reported at:
https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/thread/FITMTLVW5OBE7ZT4S7YRCD3RLGTHN2KW/

I cannot reproduce on i845G or i865G, or on i915G in Tumbleweed using the following BS packages:
Mesa-11.2.0-135.1.i586
intel-gpu-tools-1.14-1.1.i586
kernel-vanilla-4.5.2-2.1.g0454a6e.i686
libdrm_intel1-2.4.67-1.1.i586
vaapi-intel-driver-1.7.0-1.1.i586
xf86-video-intel-2.99.917-165.1.i586
xorg-x11-server-7.6_1.18.3-450.10.i586

Problem solved by installing a radeon PCIe gfxcard.

This is from dmesg tail from F24 on host gx28b:
[   87.714817] Key type id_legacy registered
[  220.384156] page:f60ee8e0 count:1 mapcount:0 mapping:  (null) index:0x0 compound_mapcount: 0
[  220.384165] flags: 0x40004000(head)
[  220.384171] page dumped because: VM_BUG_ON_PAGE(1 && PageCompound(page))
[  220.384219] ------------[ cut here ]------------
[  220.385011] kernel BUG at include/linux/page-flags.h:272!
[  220.385011] invalid opcode: 0000 [#1] SMP
[  220.385011] Modules linked in: rpcsec_gss_krb5 nfsv4 dns_resolver nfs fscache cfg80211 rfkill fuse snd_intel8x0 snd_ac97_codec iTCO_wdt ac97_bus iTCO_vendor_support snd_seq snd_seq_device ppdev gpio_ich snd_pcm dcdbas tg3 i2c_i801 ptp pps_core lpc_ich snd_timer parport_pc snd parport soundcore fjes acpi_cpufreq tpm_tis tpm nfsd auth_rpcgss nfs_acl lockd grace sunrpc i915 video i2c_algo_bit drm_kms_helper drm serio_raw ata_generic pata_acpi
[  220.385011] CPU: 0 PID: 1155 Comm: Xorg Not tainted 4.5.2-302.fc24.i686+PAE #1
[  220.385011] Hardware name: Dell Inc.                 OptiPlex GX280               /      , BIOS A07 11/29/2005
[  220.385011] task: f29f6300 ti: f290c000 task.ti: f290c000
[  220.385011] EIP: 0060:[<f850be42>] EFLAGS: 00013286 CPU: 0
[  220.385011] EIP is at drm_pci_alloc+0xc2/0x1b0 [drm]
[  220.385011] EAX: 00000000 EBX: 00004000 ECX: f7760848 EDX: 00000007
[  220.385011] ESI: f44d3fd0 EDI: c0419f90 EBP: f290db90 ESP: f290db6c
[  220.385011]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[  220.385011] CR0: 80050033 CR2: 08fe7e34 CR3: 32987d00 CR4: 000006f0
[  220.385011] Stack:
[  220.385011]  024040c0 00000000 f55d9864 f8772688 024040c0 1b9d6819 00000000 f0908a80
[  220.385011]  f0908af8 f290dba8 f86e775f 00000100 f6f9f600 f6fcab40 f6fcaf00 f290dbdc
[  220.385011]  f872e8db f4878000 f6ddcc00 f5657000 f8716501 f098d400 f6e89800 00000000
[  220.385011] Call Trace:
[  220.385011]  [<f86e775f>] i915_gem_object_attach_phys+0xef/0x190 [i915]
[  220.385011]  [<f872e8db>] intel_prepare_plane_fb+0x18b/0x300 [i915]
[  220.385011]  [<f8716501>] ? intel_crtc_destroy+0x11/0x60 [i915]
[  220.385011]  [<f80e9295>] drm_atomic_helper_prepare_planes+0x45/0xb0 [drm_kms_helper]
[  220.385011]  [<f8725fc9>] intel_atomic_commit+0x249/0x16e0 [i915]
[  220.385011]  [<f87288c6>] ? intel_atomic_check+0x886/0x10a0 [i915]
[  220.385011]  [<c05c63fd>] ? __kmalloc_track_caller+0x18d/0x230
[  220.385011]  [<f8728040>] ? intel_link_compute_m_n+0x50/0x50 [i915]
[  220.385011]  [<f8520e9f>] ? drm_atomic_check_only+0x19f/0x670 [drm]
[  220.385011]  [<f8520664>] ? drm_atomic_get_crtc_state+0x54/0xc0 [drm]
[  220.385011]  [<c058c7ca>] ? kmemdup+0x2a/0x40
[  220.385011]  [<f8725d80>] ? modeset_get_crtc_power_domains+0x140/0x140 [i915]
[  220.385011]  [<f85213a4>] drm_atomic_commit+0x34/0x60 [drm]
[  220.385011]  [<f80e9c6c>] drm_atomic_helper_update_plane+0xbc/0x100 [drm_kms_helper]
[  220.385011]  [<f80e9bb0>] ? drm_atomic_helper_wait_for_vblanks+0x210/0x210 [drm_kms_helper]
[  220.385011]  [<f8510eeb>] __setplane_internal+0x1eb/0x230 [drm]
[  220.385011]  [<f85110ae>] drm_mode_cursor_common+0x17e/0x3a0 [drm]
[  220.385011]  [<f85153b0>] ? drm_mode_setcrtc+0x570/0x570 [drm]
[  220.385011]  [<f8515407>] drm_mode_cursor_ioctl+0x57/0x70 [drm]
[  220.385011]  [<f85063f9>] drm_ioctl+0x149/0x4f0 [drm]
[  220.385011]  [<f85153b0>] ? drm_mode_setcrtc+0x570/0x570 [drm]
[  220.385011]  [<c04685be>] ? kmap_atomic_prot+0xee/0x150
[  220.385011]  [<c05a0927>] ? handle_mm_fault+0xf37/0x18a0
[  220.385011]  [<f85062b0>] ? drm_getmap+0xc0/0xc0 [drm]
[  220.385011]  [<c05ec381>] do_vfs_ioctl+0x91/0x6f0
[  220.385011]  [<c05a6cca>] ? do_mmap+0x24a/0x320
[  220.385011]  [<c05eca48>] SyS_ioctl+0x68/0x80
[  220.385011]  [<c040388f>] do_fast_syscall_32+0x8f/0x140
[  220.385011]  [<c0b2f4db>] sysenter_past_esp+0x40/0x61
[  220.385011] Code: 70 8d 82 00 00 00 40 c1 e8 0c 8d 0c 80 a1 84 e3 04 c1 8d 04 c8 8b 08 80 e5 40 74 7d 90 8d 74 26 00 ba 18 25 53 f8 e8 be d6 08 c8 <0f> 0b 8d 74 26 00 8d 55 ec 8d 45 e4 e8 dd df f0 c7 84 c0 0f 84
[  220.385011] EIP: [<f850be42>] drm_pci_alloc+0xc2/0x1b0 [drm] SS:ESP 0068:f290db6c
[  220.464100] ---[ end trace c933f60cde492adc ]---

Message from syslogd@gx28b at Apr 28 17:02:27 ...
 kernel:page:f60ee8e0 count:1 mapcount:0 mapping:  (null) index:0x0 compound_mapcount: 0

Message from syslogd@gx28b at Apr 28 17:02:27 ...
 kernel:flags: 0x40004000(head)

Message from syslogd@gx28b at Apr 28 17:02:28 ...
 kernel:CPU: 0 PID: 1155 Comm: Xorg Not tainted 4.5.2-302.fc24.i686+PAE #1

Message from syslogd@gx28b at Apr 28 17:02:28 ...
 kernel:Hardware name: Dell Inc.                 OptiPlex GX280               /      , BIOS A07 11/29/2005
Comment 3 Jeff Bastian 2016-05-25 08:23:18 EDT
I was seeing the same problem, but abrt opened a new bug 1334453.  The problem went away for me with the latest kernel-4.5.5-300.fc24.x86_64

Note You need to log in before you can comment on or make changes to this bug.