Bug 1317303 - zsh -n does not detect incorrect associative array assignment
zsh -n does not detect incorrect associative array assignment
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: zsh (Show other bugs)
7.2
All Linux
medium Severity high
: rc
: ---
Assigned To: Kamil Dudka
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 18:40 EDT by Paul Wayper
Modified: 2016-03-24 05:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-24 05:31:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wayper 2016-03-13 18:40:16 EDT
Description of problem:

zsh has the -n option to do a syntax test of the script and not actually execute it.  This test does not detect and warn on incorrect associative array declaration, whereas execution of the script breaks at that point.

Version-Release number of selected component (if applicable):

zsh 5.0.2

How reproducible:

Always

Steps to Reproduce:

###1. Create the following scripts:
$ cat zsh_array.zsh 
#!/usr/bin/zsh

typeset -A fn
fn=(foo_key foo_val bar_key bar_val)

printf %s\\n ${fn[foo_key]} ${fn[bar_key]}

$ cat zsh_bad_array.zsh 
#!/usr/bin/zsh

typeset -A fn
fn=(foo_key foo_val bar_key)

printf %s\\n $fn[foo_key] $fn[bar_key]

$ cat ksh_array.ksh 
#!/usr/bin/ksh

typeset -A fn
fn=([foo_key]=foo_val [bar_key]=bar_val)

printf %s\\n ${fn[foo_key]} ${fn[bar_key]}

###2. Test:
ksh -n ksh_array.ksh && echo result = $?
ksh ksh_array.ksh

###3. Test:
ksh -n ksh_bad_array.ksh && echo result = $?
ksh ksh_bad_array.ksh

###4. Test:
ksh -n zsh_array.zsh && echo result = $?
ksh zsh_array.zsh


Actual results:

###2. Test passes and execution passes:
$ ksh -n ksh_array.ksh && echo result = $?
result = 0
$ ksh ksh_array.ksh
foo_val
bar_val

###3. Test passes but execution fails:
$ ksh -n ksh_bad_array.ksh && echo result = $?
result = 0
$ ksh ksh_bad_array.ksh
ksh_bad_array.ksh[4]: [bar_key]: not found [No such file or directory]

###4. Test passes but execution fails:
$ ksh -n zsh_array.zsh && echo result = $?
result = 0
$ ksh zsh_array.zsh
zsh_array.zsh: line 4: cannot append index array to associative array fn

Expected results:

###2. Test passes and execution passes:
$ ksh -n ksh_array.ksh && echo result = $?
result = 0
$ ksh ksh_array.ksh
foo_val
bar_val

###3. Test passes but execution fails:
$ ksh -n ksh_bad_array.ksh && echo result = $?
ksh_bad_array.ksh[4]: [bar_key]: not found [No such file or directory]
result = 1
$ ksh ksh_bad_array.ksh
ksh_bad_array.ksh[4]: [bar_key]: not found [No such file or directory]

###4. Test passes but execution fails:
$ ksh -n zsh_array.zsh && echo result = $?
zsh_array.zsh: line 4: cannot append index array to associative array fn
result = 1
$ ksh zsh_array.zsh
zsh_array.zsh: line 4: cannot append index array to associative array fn

Additional info:

As zsh is designed to be mostly identical to ksh in execution but has a different associative array declaration syntax, zsh -n should work as a test of whether we are trying to execute a ksh or zsh shell script.
Comment 2 Kamil Dudka 2016-03-14 11:40:23 EDT
I find this bug report very difficult to understand.  The bug summary says that you want to make zsh detect incorrect uses of associative arrays ... but in the expected output you are saying that the syntax check should pass in all three cases?

Why don't you simply use the syntax that works in both ksh and zsh?

typeset -A fn
fn[foo_key]=foo_val 
fn[bar_key]=bar_val
Comment 3 Paul Wayper 2016-03-15 23:00:34 EDT
Hi Kamil,

Yes, you can use the syntax that works in both.  But they also support, and document, the multiple assignment method - the zsh wiki at:

http://zshwiki.org/home/scripting/array

gives the first example of associative array assignment as:

typeset -A buffer
buffer=( key1 val1 key2 val2 )

The syntax check should not pass in all three cases - only in test 2 (the correct multiple assignment syntax) should it pass.  Indeed, the problem is that at the moment the syntax check passes but the code is syntactically incorrect.

Hope this helps,

Paul
Comment 4 Kamil Dudka 2016-03-16 13:08:59 EDT
(In reply to Paul Wayper from comment #3)
> Yes, you can use the syntax that works in both.  But they also support, and
> document, the multiple assignment method - the zsh wiki at:
> 
> http://zshwiki.org/home/scripting/array
> 
> gives the first example of associative array assignment as:
> 
> typeset -A buffer
> buffer=( key1 val1 key2 val2 )

... and it works as documented, does not it?

> The syntax check should not pass in all three cases - only in test 2 (the
> correct multiple assignment syntax) should it pass. Indeed, the problem is
> that at the moment the syntax check passes but the code is syntactically
> incorrect.

Since shell is an interpreted language, not all "syntactical" errors could be detected without actually executing the code.

In any case, the described behavior of RHEL-7 zsh matches the behavior of upstream zsh.  Neither ksh is able detect such kinds of programming mistakes while using the -n option.  I do not think we can easily improve anything in this regard.
Comment 5 Paul Wayper 2016-03-20 23:05:37 EDT
Hi Kamil,

I'm not sure how you go from "shell is an interpreted language" to "can't detect some syntax errors".  The '-n' option specifically says in the documentation that it does a syntax check on the script.  It doesn't mention any exceptions.

I believe what you're saying is "we must go upstream to fix this bug"; would you like to start that conversation upstream or shall I?

Thanks in advance,

Paul
Comment 6 Kamil Dudka 2016-03-21 02:31:02 EDT
(In reply to Paul Wayper from comment #5)
> I'm not sure how you go from "shell is an interpreted language" to "can't
> detect some syntax errors".

zsh can detect pretty much all syntax errors.  What I am saying is that it cannot detect some syntax errors *without* actually executing the code.  Obviously, all languages that support 'eval' and the like have to have some limitations in this regard.

> The '-n' option specifically says in the
> documentation that it does a syntax check on the script.  It doesn't mention
> any exceptions.

Which documentation?

If it says that all syntax errors are guaranteed to be reported, we just need to reword the documentation.

> I believe what you're saying is "we must go upstream to fix this bug"; would
> you like to start that conversation upstream or shall I?

Please do.
Comment 7 Paul Wayper 2016-03-22 18:15:17 EDT
OK, this is what I've written to the zsh-workers@zsh.org address:

Hi there!

Sourceforge has pointed me to this list as a way to get a bug fixed in zsh.

I've discovered that an incorrect associative array declaration in zsh isn't detected via 'zsh -n script.zsh', even though it does get flagged when the script is executed.  For example:

$ cat zsh_array.zsh 
#!/usr/bin/zsh

typeset -A fn
fn=(foo_key foo_val bar_key bar_val)

printf %s\\n ${fn[foo_key]} ${fn[bar_key]}

$ cat zsh_bad_array.zsh 
#!/usr/bin/zsh

typeset -A fn
fn=(foo_key foo_val bar_key)

printf %s\\n $fn[foo_key] $fn[bar_key]

$ zsh -n zsh_array.zsh && echo $?
0
$ zsh zsh_array.zsh
foo_val bar_val

# And yet:
$ zsh -n zsh_bad_array.zsh && echo $?
0
$ zsh zsh_bad_array.zsh
/tmp/zsh_bad_array.zsh:4: bad set of key/value pairs for associative array


This syntax for associative array declaration is the one documented as correct:

http://zshwiki.org/home/scripting/array

gives the first example of associative array assignment as:

typeset -A buffer
buffer=( key1 val1 key2 val2 )

Ideally what I'd like is for zsh -n to give the same error message on an incorrect associative array declaration as zsh gives when executing the script.

Thanks in advance,

Paul
Comment 8 Kamil Dudka 2016-03-23 03:25:46 EDT
(In reply to Paul Wayper from comment #7)
> OK, this is what I've written to the zsh-workers at zsh dot org address:

... and this is the response from upstream developers (not a bug):

http://www.zsh.org/mla/workers/2016/msg00742.html
Comment 9 Kamil Dudka 2016-03-24 05:31:15 EDT
zsh (as well as other shells) is not designed to detect this kind of programming mistakes without actually executing the code.  Please suggest the customer to use the solution proposed in comment #2.

Note You need to log in before you can comment on or make changes to this bug.