This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1317309 - 3.6.9 Client Installs on Debian Wheezy, but Held Back on Jessie
3.6.9 Client Installs on Debian Wheezy, but Held Back on Jessie
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: packaging (Show other bugs)
3.6.9
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 19:58 EDT by junk
Modified: 2016-04-12 07:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-11 14:05:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description junk 2016-03-13 19:58:42 EDT
Description of problem:

The 3.6.9 update of GlusterFS client (unlike all previous updates) is "held back" on Jessie (Debian 8).  It installs fine on Wheezy (Debian 7).

This is extremely odd, since Jessie is the *newer* distribution.

Attempting to force-install the component gives:

The following packages have unmet dependencies:
 glusterfs-common:
   Depends: liblvm2app2.2 (>= 2.02.142) but 2.02.111-2.2 is to be installed
   Depends: libncurses5 (>= 6) but 5.9+20140913-1+b1 is to be installed
   Depends: libssl1.0.2 (>= 1.0.2d) but it is not installable
   Depends: libtinfo5 (>= 6) but 5.9+20140913-1+b1 is to be installed


Version-Release number of selected component (if applicable):


How reproducible:

On any Debian 8 (Jessie) system, simply apt-get install glusterfs-common when you have a sources.list file containing:

deb [arch=amd64] http://download.gluster.org/pub/gluster/glusterfs/3.6/LATEST/Debian/jessie/apt jessie main

Steps to Reproduce:
1. Attempt to upgrade 3.6.8 glusterfs client/common on Debian 8/Jessie to 3.6.9
2. Packages are held back.
3. Attempt to force-upgrade.
4. Receive indication of unavailable required packages.

Actual results:

Unable to install, due to "missing" packages (older versions available, newer versions required).

Expected results:

Installation successful, as with all prior versions.

Additional info:

If this is something that is 'in the pipeline' or being worked on (or, for some unfathomable reason, completely impossible), can we get some documentation of this somewhere?

If this had not installed on Wheezy, I would be much less surprised -- but as it has installed successfully on Wheezy, but refuses to do so on Jessie, this seems quite odd.

Thanks!
Comment 1 Kaleb KEITHLEY 2016-04-11 14:05:18 EDT
/var/cache/pbuilder/apt-cache was polluted with incorrect (newer) versions of dependencies.

Rebuilt cache and rebuilt packages now have correct dependencies.
Comment 2 junk 2016-04-12 07:40:30 EDT
I can confirm that this is now corrected, and the glusterfs client installs correctly on my jessie instance.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.