Bug 1317312 - With latest puddles of RHOSP 8.0, "openstack flavor delete" fails with "public endpoint for messaging service not found"
Summary: With latest puddles of RHOSP 8.0, "openstack flavor delete" fails with "publi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: RHOS Maint
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-14 00:12 UTC by David Hill
Modified: 2016-08-11 11:29 UTC (History)
11 users (show)

Fixed In Version: python-tripleoclient-2.0.0-1.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 11:29:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
openstack flavor delete (8.19 KB, text/plain)
2016-03-15 13:34 UTC, Dimitri Savineau
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC

Description David Hill 2016-03-14 00:12:02 UTC
Description of problem:
With latest puddles of RHOSP 8.0, "openstack flavor delete" fails with "public endpoint for messaging service not found" but "nova flavor-delete" succeeds

Version-Release number of selected component (if applicable):


How reproducible:
[stack@undercloud-0-rhosp8 ~]$ openstack flavor delete compute
public endpoint for messaging service not found


[stack@undercloud-0-rhosp8 ~]$ nova flavor-delete compute
+--------------------------------------+---------+-----------+------+-----------+------+-------+-------------+-----------+
| ID                                   | Name    | Memory_MB | Disk | Ephemeral | Swap | VCPUs | RXTX_Factor | Is_Public |
+--------------------------------------+---------+-----------+------+-----------+------+-------+-------------+-----------+
| 778d6fdc-ce9d-42aa-a6c6-e7732034a503 | compute | 4096      | 40   | 0         |      | 1     | 1.0         | True      |
+--------------------------------------+---------+-----------+------+-----------+------+-------+-------------+-----------+



Steps to Reproduce:
1. Install latest undercloud
2. Try to delete the default flavors
3.

Actual results:
Fails

Expected results:
Succeeds

Additional info:

----------------------+----------------------------------------+----------------------------------+
|                id                |   region  |                  publicurl                  |                 internalurl                 |                adminurl                |            service_id            |
+----------------------------------+-----------+---------------------------------------------+---------------------------------------------+----------------------------------------+----------------------------------+
| 1f4e955b657341bfaa87ed3f678e1c87 | regionOne |           http://192.0.2.1:8774/v3          |           http://192.0.2.1:8774/v3          |        http://192.0.2.1:8774/v3        | 9615dcfa802946b3b1ce4ce73cb95c8f |
| 240dd3d4a8164908a4a48f3b8f3ec48b | regionOne |            http://192.0.2.1:8042            |            http://192.0.2.1:8042            |         http://192.0.2.1:8042          | ff703cce75444794a50adb003d1de578 |
| 24c48e58f3e6413aadff8660108db08d | regionOne |            http://192.0.2.1:6385            |            http://192.0.2.1:6385            |         http://192.0.2.1:6385          | 271217283d324f9d8d318c13be3a9023 |
| 2b7c0d2b18184860bf8a8f07bd45673f | regionOne | http://192.0.2.1:8080/v1/AUTH_%(tenant_id)s | http://192.0.2.1:8080/v1/AUTH_%(tenant_id)s |         http://192.0.2.1:8080          | c2719fd8b9dd496db7505b2849bd73a7 |
| 67dd9f93f383460aaa7c2e617e9c107a | regionOne |            http://192.0.2.1:9696            |            http://192.0.2.1:9696            |         http://192.0.2.1:9696          | 6a5d97f4889349b8bf6aadbde8a03192 |
| 8b5c2edf0f734f3bb613f3f7c0f5862b | regionOne |    http://192.0.2.1:8004/v1/%(tenant_id)s   |    http://192.0.2.1:8004/v1/%(tenant_id)s   | http://192.0.2.1:8004/v1/%(tenant_id)s | 5be142782c3a4a4ba02c11afc9c89a1f |
| d30a53bd9729475289bd6d98624d6a8d | regionOne |    http://192.0.2.1:8774/v2/%(tenant_id)s   |    http://192.0.2.1:8774/v2/%(tenant_id)s   | http://192.0.2.1:8774/v2/%(tenant_id)s | ac063e4a4fe24b0c8d9446d42f157b3e |
| de2a02625bc04195a18c429d65476a92 | regionOne |            http://192.0.2.1:9292            |            http://192.0.2.1:9292            |         http://192.0.2.1:9292          | 58b9e6f56c27455c9e46eda877d48236 |
| e03def6579394e8baf924aff43fe70ae | regionOne |          http://192.0.2.1:5000/v2.0         |          http://192.0.2.1:5000/v2.0         |      http://192.0.2.1:35357//v2.0      | ad8bd0228bf44892a22b396ff82987a2 |
| e0b87d78cb7a41ee8f9874995a304276 | regionOne |            http://192.0.2.1:8777            |            http://192.0.2.1:8777            |         http://192.0.2.1:8777          | a65579f83f6d4592954d029fa5d82b0a |
+----------------------------------+-----------+---------------------------------------------+---------------------------------------------+----------------------------------------+----------------------------------+

Comment 1 Dimitri Savineau 2016-03-15 13:32:37 UTC
Same problem with latest RHOS 8 puddle (03/11).

In fact "flavor delete" command from python-zaqarclient overrides the "flavor delete" from python-openstackclient.

https://github.com/openstack/python-openstackclient/blob/stable/liberty/setup.cfg#L76
https://github.com/openstack/python-zaqarclient/blob/stable/liberty/setup.cfg#L56

The issue has been fixed upstream ("flavor delete" renamed in python-zaqarclient) but not backport in liberty

https://bugs.launchpad.net/python-zaqarclient/+bug/1506957

Comment 2 Dimitri Savineau 2016-03-15 13:34:01 UTC
Created attachment 1136603 [details]
openstack flavor delete

Comment 3 Gaëtan Trellu 2016-03-21 17:52:17 UTC
Same error with the puddle of 18th march.

Comment 4 Mike Burns 2016-04-07 21:14:44 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 5 Dimitri Savineau 2016-04-07 21:49:04 UTC
Mike, this bug only affects OSP 8 because the fix is already present in Mitaka since Oct 2015 so set the target to OSP 10 makes no sense.

Comment 6 Mike Burns 2016-04-07 22:05:35 UTC
Not a problem, moving back to 9 and marking MODIFIED

Comment 9 Alexander Chuzhoy 2016-06-08 20:00:02 UTC
Verified:
Environment:
python-tripleoclient-2.0.0-1.0.2.el7ost.noarch





[stack@instack ~]$ openstack flavor list
+--------------------------------------+---------------+------+------+-----------+-------+-----------+
| ID                                   | Name          |  RAM | Disk | Ephemeral | VCPUs | Is Public |
+--------------------------------------+---------------+------+------+-----------+-------+-----------+
| 1a702766-9c4c-4a56-8bf8-867b1843e87a | baremetal     | 4096 |   40 |         0 |     1 | True      |
| 3ecc9455-c80d-48fa-a9ec-a6c2880c2894 | compute       | 4096 |   40 |         0 |     1 | True      |
| 41323b6b-190f-4c49-82c5-90c2fb8b71f6 | swift-storage | 4096 |   40 |         0 |     1 | True      |
| 4ba0262b-a677-4661-afa0-c7f2252d4ce4 | block-storage | 4096 |   40 |         0 |     1 | True      |
| d9320eb8-f387-464b-9f66-7f101953fd03 | control       | 4096 |   40 |         0 |     1 | True      |
| dd20586d-07ec-4fb7-ad93-ec88eba2ce69 | ceph-storage  | 4096 |   40 |         0 |     1 | True      |
+--------------------------------------+---------------+------+------+-----------+-------+-----------+

[stack@instack ~]$  openstack flavor delete compute

[stack@instack ~]$ openstack flavor list
+--------------------------------------+---------------+------+------+-----------+-------+-----------+
| ID                                   | Name          |  RAM | Disk | Ephemeral | VCPUs | Is Public |
+--------------------------------------+---------------+------+------+-----------+-------+-----------+
| 1a702766-9c4c-4a56-8bf8-867b1843e87a | baremetal     | 4096 |   40 |         0 |     1 | True      |
| 41323b6b-190f-4c49-82c5-90c2fb8b71f6 | swift-storage | 4096 |   40 |         0 |     1 | True      |
| 4ba0262b-a677-4661-afa0-c7f2252d4ce4 | block-storage | 4096 |   40 |         0 |     1 | True      |
| d9320eb8-f387-464b-9f66-7f101953fd03 | control       | 4096 |   40 |         0 |     1 | True      |
| dd20586d-07ec-4fb7-ad93-ec88eba2ce69 | ceph-storage  | 4096 |   40 |         0 |     1 | True      |
+--------------------------------------+---------------+------+------+-----------+-------+-----------+

Comment 12 errata-xmlrpc 2016-08-11 11:29:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.