Bug 1317373 - gi.overrides.BlockDev.LVMError: Process reported exit code 768: Size is not a multiple of 512. Try using 756641792 or 756642304.
gi.overrides.BlockDev.LVMError: Process reported exit code 768: Size is not...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libblockdev (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
abrt_hash:24d5b86287557dfc70b9e77dc63...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-14 02:54 EDT by lnie
Modified: 2016-06-18 14:51 EDT (History)
7 users (show)

See Also:
Fixed In Version: libblockdev-1.6-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-18 14:51:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.31 MB, text/plain)
2016-03-14 02:58 EDT, lnie
no flags Details
File: anaconda.log (122.00 KB, text/plain)
2016-03-14 02:58 EDT, lnie
no flags Details
File: dnf.log (2.61 KB, text/plain)
2016-03-14 02:58 EDT, lnie
no flags Details
File: environ (459 bytes, text/plain)
2016-03-14 02:58 EDT, lnie
no flags Details
File: lsblk_output (4.17 KB, text/plain)
2016-03-14 02:58 EDT, lnie
no flags Details
File: lvm.log (348.46 KB, text/plain)
2016-03-14 02:59 EDT, lnie
no flags Details
File: nmcli_dev_list (1.21 KB, text/plain)
2016-03-14 02:59 EDT, lnie
no flags Details
File: os_info (449 bytes, text/plain)
2016-03-14 02:59 EDT, lnie
no flags Details
File: program.log (38.64 KB, text/plain)
2016-03-14 02:59 EDT, lnie
no flags Details
File: storage.log (313.22 KB, text/plain)
2016-03-14 03:00 EDT, lnie
no flags Details
File: syslog (423.40 KB, text/plain)
2016-03-14 03:01 EDT, lnie
no flags Details
File: ifcfg.log (2.40 KB, text/plain)
2016-03-14 03:01 EDT, lnie
no flags Details
File: packaging.log (1.32 KB, text/plain)
2016-03-14 03:01 EDT, lnie
no flags Details
reproduce video (887.82 KB, application/octet-stream)
2016-03-14 03:40 EDT, lnie
no flags Details
screenshot (170.41 KB, image/png)
2016-03-14 03:48 EDT, lnie
no flags Details

  None (edit)
Description lnie 2016-03-14 02:54:35 EDT
Description of problem:
This crash happens everytime when I'm trying to install f24 on two storage devices on my vm and set the device type to Lvm Thin Provisioning

Version-Release number of selected component:
anaconda-24.13-1

The following was filed automatically by anaconda:
anaconda 24.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/gi/overrides/BlockDev.py", line 416, in wrapped
    raise transform[1](msg)
  File "/usr/lib/python3.5/site-packages/blivet/devices/lvm.py", line 1622, in _create
    self.size)
  File "/usr/lib/python3.5/site-packages/blivet/devices/storage.py", line 457, in create
    self._create()
  File "/usr/lib/python3.5/site-packages/blivet/deviceaction.py", line 312, in execute
    self.device.create()
  File "/usr/lib/python3.5/site-packages/blivet/actionlist.py", line 280, in process
    action.execute(callbacks)
  File "/usr/lib/python3.5/site-packages/blivet/devicetree.py", line 381, in processActions
    callbacks=callbacks)
  File "/usr/lib/python3.5/site-packages/blivet/blivet.py", line 164, in doIt
    self.devicetree.processActions(callbacks=callbacks)
  File "/usr/lib/python3.5/site-packages/blivet/osinstall.py", line 1096, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/install.py", line 195, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib64/python3.5/threading.py", line 862, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
gi.overrides.BlockDev.LVMError: Process reported exit code 768:   Size is not a multiple of 512. Try using 756641792 or 756642304.
  Invalid argument for --virtualsize: 756641955b
  Error during parsing of command line.


Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-rawh rd.live.check quiet
dnf.rpm.log:    Mar 14 06:47:06 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        24
Comment 1 lnie 2016-03-14 02:58:04 EDT
Created attachment 1136060 [details]
File: anaconda-tb
Comment 2 lnie 2016-03-14 02:58:21 EDT
Created attachment 1136061 [details]
File: anaconda.log
Comment 3 lnie 2016-03-14 02:58:23 EDT
Created attachment 1136062 [details]
File: dnf.log
Comment 4 lnie 2016-03-14 02:58:24 EDT
Created attachment 1136063 [details]
File: environ
Comment 5 lnie 2016-03-14 02:58:26 EDT
Created attachment 1136064 [details]
File: lsblk_output
Comment 6 lnie 2016-03-14 02:59:21 EDT
Created attachment 1136065 [details]
File: lvm.log
Comment 7 lnie 2016-03-14 02:59:22 EDT
Created attachment 1136066 [details]
File: nmcli_dev_list
Comment 8 lnie 2016-03-14 02:59:24 EDT
Created attachment 1136067 [details]
File: os_info
Comment 9 lnie 2016-03-14 02:59:27 EDT
Created attachment 1136068 [details]
File: program.log
Comment 10 lnie 2016-03-14 03:00:14 EDT
Created attachment 1136069 [details]
File: storage.log
Comment 11 lnie 2016-03-14 03:01:18 EDT
Created attachment 1136071 [details]
File: syslog
Comment 12 lnie 2016-03-14 03:01:20 EDT
Created attachment 1136073 [details]
File: ifcfg.log
Comment 13 lnie 2016-03-14 03:01:22 EDT
Created attachment 1136074 [details]
File: packaging.log
Comment 14 lnie 2016-03-14 03:39:27 EDT
It seems that it's not two storage devices' fault,I can reproduce this on a single storage device when I'm trying to spare more space from swap to /boot.
Comment 15 lnie 2016-03-14 03:40 EDT
Created attachment 1136086 [details]
reproduce video
Comment 16 lnie 2016-03-14 03:47:04 EDT
I first saw this crash when I'm using the workstation-live,but failed to finish the bug report because of the workstations-live's network issues.
Comment 17 lnie 2016-03-14 03:48 EDT
Created attachment 1136088 [details]
screenshot
Comment 18 Vratislav Podzimek 2016-04-05 05:15:32 EDT
The pull request with the fix for this issue can be found at:
https://github.com/rhinstaller/libblockdev/pull/77
Comment 19 Fedora Update System 2016-06-01 07:34:44 EDT
libblockdev-1.6-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8b5973c5e4
Comment 20 Fedora Update System 2016-06-02 05:01:18 EDT
libblockdev-1.6-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8b5973c5e4
Comment 21 Fedora Update System 2016-06-18 14:51:32 EDT
libblockdev-1.6-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.