Bug 1317424 - nfs-ganesha server do not enter grace period during failover/failback
nfs-ganesha server do not enter grace period during failover/failback
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: common-ha (Show other bugs)
mainline
All All
unspecified Severity medium
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Triaged
Depends On: 1290865
Blocks: 1278332
  Show dependency treegraph
 
Reported: 2016-03-14 04:50 EDT by Kaleb KEITHLEY
Modified: 2016-06-16 10:00 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290865
Environment:
Last Closed: 2016-06-16 10:00:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-14 07:45:53 EDT
REVIEW: http://review.gluster.org/13728 (ganesha-ha: merge release-3.7 to master for release-3.8) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Vijay Bellur 2016-03-15 03:26:09 EDT
COMMIT: http://review.gluster.org/13728 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 53d81d9eced2b65c782c77a6f44ef343578eb3c7
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Mon Mar 14 07:41:11 2016 -0400

    ganesha-ha: merge release-3.7 to master for release-3.8
    
    cherry-pick changes from release-3.7 branch to master in preparation
    for 3.8
    
    changes merged/cherry-picked from release-3.7 consist of:
    
    > common-ha: delete virt-IP entry of deleted node
    > commit aee983ff43655771a9102592a284d0b0a29ad89f
    > BUG: 1250601
    >
    > common-ha: concise output for HA status
    > commit d804b17f2fe92b1516f85f03978072c42ddc6f19
    > BUG: 1250628
    >
    > common-ha : refresh-config should print sensible output
    > commit d7adcca24fb9638df2806c01d8ea7e73eec46928
    > BUG: 1254494
    >
    > CommonHA: Avoid scp of the config state to the same host
    > commit 07b31a008b59d6c0b06bd17994de85fc56560b38
    > BUG: 1259225
    >
    > CommonHA: Fix the path of 'systemctl' cmd
    > commit 8e7ca068720fa6fa50e4746e5b17c305f38171e8
    > BUG: 1259225
    >
    > common-ha: refresh-config output includes dbus "method return" msg
    > commit 045cb34238e341d68288893b8f040056e138c04e
    > BUG: 1262881
    >
    > common-ha: distribution neutral location of config files
    > commit 6667478cdba920d2658bba2edc99c8f8cc33e271
    > BUG: 1251821
    >
    > common-ha: Corrected refresh-config output parsing
    > commit 2892bab69cac2d991509fca1279a659bce1ae793
    > BUG: 1254494
    >
    > common-ha: reliable grace using pacemaker notify actions
    > commit e8121c4afb3680f532b450872b5a3ffcb3766a97
    > BUG: 1290865
    >
    > ganesha: Read export_id on each node while performing refresh-config
    > commit e0e633cdce7586af92490730257ed7f0cffcff61
    > BUG: 1309238
    >
    > nfs-ganesha: pcs cluster setup needs '--name' option
    > commit 812e7321d3c56d329526628fe96a8f6fabea75ca
    > BUG: 1314204
    
    Change-Id: I41c19bd369bd9da1092b0677590634a4e9f72813
    BUG: 1317424
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13728
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Niels de Vos 2016-06-16 10:00:28 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.